Children of the Candy Corn [bfs][dfs]

13 篇文章 0 订阅
本文介绍了如何使用BFS寻找迷宫的最短路径,以及利用DFS找出遵循左墙或右墙策略的路径。在输入迷宫后,通过算法计算出各个路径经过的格子数,帮助设计出更复杂的迷宫布局。
摘要由CSDN通过智能技术生成

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there’s no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn’t work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)

As the proprieter of a cornfield that is about to be converted into a maze, you’d like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks (‘#’), empty space by periods (‘.’), the start by an ‘S’ and the exit by an ‘E’.

Exactly one ‘S’ and one ‘E’ will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls (‘#’), with the only openings being the ‘S’ and ‘E’. The ‘S’ and ‘E’ will also be separated by at least one wall (‘#’).

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the ‘S’ and ‘E’) for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input
2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########
Sample Output
37 5 5
17 17 9

题解

迷宫算法有个贪心算法就是右墙优先算法,计算机导论老师讲机器人走迷宫时讲过。右边通往右转否则前面通前走否则左边同左转否则后转,走一遍能走出迷宫,该算法对我们ACM没有什么利用价值。对于这个题知道按它走一遍即可。

用bfs找最短路。dfs找left or right优先路径。
巧用模运算,以动态对应不同状态下的上下左右,如此可以省略相当一部分代码。

//Accepted 604kB 0ms
#include<stdio.h>
#include<string.h>
#include<queue>
#define MAX_N 42
using namespace std;
char map[MAX_N][MAX_N];
int best[MAX_N][MAX_N];
int W,H,s_x,s_y,e_x,e_y;

//一次是 左 上 右 下
int ox[]={0,1,0,-1};
int oy[]={-1,0,1,0};

int bfs(){
    memset(best,-1,sizeof(best));
    queue<pair<int,int> > que;
    que.push(make_pair(s_x,s_y));
    best[s_x][s_y]=1;

    while(!que.empty()){
        int X=que.front().first,Y=que.front().second;que.pop();
        int step=best[X][Y];
        if(X==e_x&&Y==e_y) return step;
        for(int i=0;i<4;i++){
            int x=X+ox[i];
            int y=Y+oy[i];
            if(0<=x&&x<H&&0<=y&&y<W&&map[x][y]=='.'&&best[x][y]==-1){
                best[x][y]=step+1;
                que.push(make_pair(x,y));
            }
        }
    }
    return -1;
}

int dfs1(int X,int Y,int op){
    if(X==e_x&&Y==e_y) return 1;
    for(int i=0;i<4;i++){
        int x=X+ox[(i+op)%4];
        int y=Y+oy[(i+op)%4];
        if(0<=x&&x<H&&0<=y&&y<W&&map[x][y]=='.')
            return dfs1(x,y,(i+op+3)%4)+1;
    }
}
//一次是 右 上 左 下
int Ox[]={0,1,0,-1};
int Oy[]={1,0,-1,0};
int dfs2(int X,int Y,int op){
    if(X==e_x&&Y==e_y) return 1;
    for(int i=0;i<4;i++){
        int x=X+Ox[(i+op)%4];
        int y=Y+Oy[(i+op)%4];
        if(0<=x&&x<H&&0<=y&&y<W&&map[x][y]=='.')
            return dfs2(x,y,(i+op+3)%4)+1;
    }
}
int sove_b(){

}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&W,&H);
        for(int i=0;i<H;i++)
            scanf("%s",map[i]);
        for(int k=0;k<H;k++)
            for(int j=0;j<W;j++)
                if(map[k][j]=='S') s_x=k,s_y=j;
                else if(map[k][j]=='E'){
                    map[k][j]='.';
                    e_x=k,e_y=j;
                }
        int a=dfs1(s_x,s_y,0);
        int b=dfs2(s_x,s_y,0);
        int ans=bfs();
        printf("%d %d %d\n",b,a,ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值