PAT 1052 Linked List Sorting (25分)

原题链接:1052 Linked List Sorting (25分)
关键词:链表、排序
整理时间:2020.7.24

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<10​5​​) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10​5​​,10​5​​], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.
Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题目大意: 给出一个链表,请你按照 Key 值升序的顺序将链表重新排序。

思路: 设置结点的结构体数组,循环把所有结点输入数组。然后根据链表起始节点的地址,进行遍历,并标记flag为1,count++。count最后得出的就是链表中的结点数。使用sort按照题目给的规则进行排序,最后输出。
主要步骤可以参考:静态链表
代码:

#include <iostream>
#include <algorithm>
using namespace std;

const int N = 100000 + 10;
struct node{
    int address;
    int data;    
    int next;
    bool flag = 0;  //判断是否在链表上
}a[N];

bool cmp(node a, node b){
    if(a.flag == false || b.flag == false) return a.flag > b.flag;  //a和b中只要有一个无效结点就把它放到后面
    return a.data < b.data; //都是有效结点,则按要求排序
    
}

int main(){
    int n, begin, address, data, next;
    scanf("%d%d", &n, &begin);
    for(int i = 0; i < n; i ++ ){   //把结点存入数组
        scanf("%d%d%d", &address, &data, &next);
        a[address].address = address;
        a[address].data = data;
        a[address].next = next;
    }
    
    int p, count = 0;
    for(p = begin; p != -1; p = a[p].next ){
        a[p].flag = 1;
        count++;
    }
    sort(a, a+N, cmp);
    if(count == 0) printf("0 -1");  //特判,当链表中没有结点时
    else{
        printf("%d %05d\n", count, a[0].address);
        for(int i = 0; i < count; i ++ ){
            if(i != count-1) printf("%05d %d %05d\n", a[i].address, a[i].data, a[i+1].address);
            else printf("%05d %d -1\n", a[i].address, a[i].data);
        }
    }
    return 0;
}

注意:

  1. -1不能使用%05d进行格式输出,因为输出结果会是-0001而不是-1或者-00001,需要多写一个if进行判断。根据有效结点的个数count,第count-1位应当就是链表的最后结点。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值