Ubuntu 18.04 安装Tensorflow遇到的问题

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/cyn618/article/details/79997960

问题一:

Tensorflow安装完成后测试时,出现libcublas.so.9.0找不到问题:

ImportError: libcublas.so.9.0: cannot open shared object file: No such file or directory

问题原因:

使用官网上pip命令安装的tensorflow版本基于的是cuda9.0,而nvidia官网最新的是cuda9.1。如果安装的不是9.0,就会出现该问题。

解决方法:

可以使用tensorflow源码编译支持cuda9.1版本,最简单方法是卸载cuda9.1,安装cuda9.0。

参考:https://github.com/tensorflow/tensorflow/issues/18237


问题二:

安装cuDNN后运行测试用例时,出现以下问题:

/usr/local/cuda/include/crt/host_config.h:119:2: error: #error -- unsupported GNU version! gcc versions later than 6 are not supported!
 #error -- unsupported GNU version! gcc versions later than 6 are not supported!
  ^~~~~

解决方法:

首先安装version小于6的gcc和g++,我安装的是版本6:

sudo apt-get install gcc-6
sudo apt-get install g++-6

然后创建软链接到cuda安装目录:

sudo ln -s /usr/bin/gcc-6 /usr/local/cuda/bin/gcc
sudo ln -s /usr/bin/g++-6 /usr/local/cuda/bin/g++
参考:https://stackoverflow.com/questions/6622454/cuda-incompatible-with-my-gcc-version


阅读更多

没有更多推荐了,返回首页