1014

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer[i] will take T[i] minutes to have his/her transaction processed.
he first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output “Sorry” instead.
Sample Input

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output

08:07
08:06
08:10
17:00
Sorry

题意:银行有N个窗口,每个窗口可排队M人,前面N*M人按顺序依次排队,后面的人依次插入空缺(同时又空缺选择窗口号小的),银行每天17:00关门,17:00(不含)前排上队的即使超17:00也可服务(神坑)。求某些人服务结束时间。
思路:银行每个窗口看成一个队列,每个窗口有当前服务者完成服务后的时间poptime,队列最后一个人完成的时间endtime。每轮遍历选**poptime最小者加进一人,同时将此人的完成时间记下。
坑爹处:
17:00(不含)前排上队的即使超17:00也可服务。
C语言函数调用结构体数组,应把整个数组作为参数,同时传递要操作的下标:void AddQueue(int a, Queue Q[], int i);

#include <stdio.h>

typedef struct queue
{
    int poptime;
    int endtime;
    int front;
    int last;
    int people[11];
}Queue;

int N,M,K,Q;
int prot[1001] = {0};
int query[1001] = {0};
int time[1001] = {0};
Queue Que[21];

void AddQueue(int person, Queue Q[], int i);
void DeleQueue(Queue Q[], int i);

int main()
{
    scanf("%d%d%d%d", &N, &M, &K, &Q);
    int i;
    for(i=1;i<K+1;i++)
    {
        scanf("%d", &prot[i]);
    }
    for(i=0;i<Q;i++)
    {
        scanf("%d", &query[i]);
    }

    for(i=0;i<20;i++)
    {
        Que[i].poptime = prot[i+1];
        Que[i].endtime = Que[i].front = Que[i].last = 0;
    }

    int pi=1;
    for(i=0;i<M;i++)
    {
        int j;
        for(j=0;j<N;j++)
        {
            if(pi>K)
                break;
            else
                AddQueue(pi++, Que, j);
        }
    }

    for(i=pi;i<K+1;i++)
    {
        int j;
        int mintime = Que[0].poptime;
        int window = 0;
        for(j=1;j<N;j++)
        {
            if(Que[j].poptime < mintime)
            {
                window = j;
                mintime = Que[j].poptime;
            }
        }
        DeleQueue(Que, window);
        AddQueue(i, Que, window);
    }

    for(i=0;i<Q;i++)
    {
        if(time[query[i]] - prot[query[i]] >= 540)
        {
            printf("Sorry\n");
        }
        else
        {
            printf("%02d:%02d\n", time[query[i]]/60+8, time[query[i]]%60);
        }
    }
    return 0;
}

void AddQueue(int person, Queue Q[], int i)
{

    Q[i].people[Q[i].last] = person;
    if(Q[i].last+1 == M)
    {
        Q[i].last = 0;
    }
    else
    {
        Q[i].last = Q[i].last + 1;
    }
    Q[i].endtime += prot[person];
    time[person] = Q[i].endtime;
}

void DeleQueue(Queue Q[], int i)
{
    int person = Q[i].people[Q[i].front];
    if(Q[i].front+1 == M)
    {
        Q[i].front =0;
    }
    else
    {
        Q[i].front = Q[i].front + 1;
    }
    Q[i].poptime += prot[Q[i].people[Q[i].front]];
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值