phpStorm配置svn提示:Can't use Subversion command line client

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/daijiguo/article/details/50440425

使用phpStorm的svn时提示出错:Can't use Subversion command line client: svn.                                  

当我在使用svn,Checkout一个项目后,然后将其导入到Intellij中,就出现这样的报错!

经过google后,明白了,我的问题是:我安装的TortoiseSVN工具,本身不是带有command-line功能的,必须要安装VisualSVN,而且须要单独安装。 

下载地址:http://subversion.apache.org/packages.html 选择需要下载的版本,例如我是下载的win版本的。

如图所示: 

  

windows版本的下载地址:https://www.visualsvn.com/files/Apache-Subversion-1.8.13.zip

最后解压,将Apache-Subversion-1.8.13\bin\svn.exe的绝对path直接配置到Use command line client 如图所示: 

例如我的是:E:\Program Files\Apache-Subversion-1.8.13\bin\svn.exe 

保存就ok!解决报错!

没有更多推荐了,返回首页