mac idea gradle 编译spring源码


Gradle安装

spring5官方推荐4.0,下载链接:https://gradle.org/next-steps/?version=4.0&format=bin
注意这里不要用5.x,下面记录了一个关于gradle版本的错误,少走坑。

后面就是下载、解压。
配置环境变量:

vi /etc/profile

export GRADLE_HOME=/Users/leesin/gradle-4.0
export PATH=$PATH:$GRADLE_HOME/bin

source /etc/profile

gradle -v 

Idea编译

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
gradle路径,在https://blog.csdn.net/u012211419/article/details/80445276这篇博文中,博主说必须是到libexec目录下,但是我没有找到这个目录,而且我用我这个目录配置也确实成功了。

jdk版本注意,1.8以上
在这里插入图片描述
构建的时间有点久,应该有个十分钟吧。但是我是第一次用Gradle的原因可能,构建好了,但是后面足足等了几个小时才彻底好,在下载东西,电脑卡出翔~

在这里插入图片描述
最终如上观察

  1. 项目的目录结构变成了如上的蓝色小标志,不知道怎么表达,懂得的自然懂,你懂我的意思吧
  2. shift+option+command+u 出现类图,或者右键Diagrams–>show diagrams
  3. 刷新gradle,且没有报错。

问题记录

Gradle版本过高

在这里插入图片描述
但是spring源码是需要的4开头的版本
我的gradle
在这里插入图片描述
This version of Gradle requires version 2.0.2 of the build scan plugin or later.当前版本过高。
在这里插入图片描述

Java环境冲突

来自某高阶Java视频的记录

如果项目环境一直无法构建,项目文件夹没有变粗体字,类图无法自动生成。那么你一定是踩到了这样一个坑。
第一步:首先打开 View->Tool Windows -> Gradle
在这里插入图片描述
然后,点击右侧 Gradle 视图中的 Refresh,会出现如下的错误:
在这里插入图片描述
在这里插入图片描述
第二步:看错误,显然跟 Gradle 没有任何关系,解决办法:
1.关闭 IDEA,打开任务管理器,结束跟 java 有关的所有进程。
2.找到 JAVA_HOME -> jre -> lib 目录,将 tools.jar 重命名 tools.jar.bak。
3.重启 IDEA,再次点击 refresh,等待构建完成。
为什么会有这个错误?
我们的编辑器有一个java环境,自己的jdk有一个Java环境,两个jar包有冲突,不知道用哪个个,所以把其中一个隐藏掉

参考:

https://blog.csdn.net/u012211419/article/details/80445276
https://www.jianshu.com/p/9a623bdc5c51

发布了508 篇原创文章 · 获赞 2204 · 访问量 187万+

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览