Color the ball

Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

 

Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

 

Sample Output
1 1 1 3 2 1
 

 

Author
8600
 

 

Source
 

 

Recommend
LL   |   We have carefully selected several similar problems for you:   1166  1542  1394  1698  1255 
主要是延时标记这个需要特别注意,由于那个每次区间更新时候,涉及到的叶子节点是不止一个的一般,从而叶子节点会影响其相应的非叶父节点,所以回溯需要更新的非叶子节点也会有很多,以至于会出现超时的情况
贴一个详说这点的博客http://blog.sina.com.cn/s/blog_a2dce6b30101l8bi.html
 
#include<iostream>
#include<cstdio>
typedef  long long LL;
const int maxn=100005;
using namespace std;
LL sum[maxn<<2];
void build(int l,int r,int root){
sum[root]=0;
if(l==r){
	return;
}
int mid=(l+r)>>1;
build(l,mid,root<<1);
build(mid+1,r,root<<1|1);
}
void update(int l,int r,int L,int R,int root){
	if(L<=l&&R>=r){
		sum[root]++;//延时标记 
		return ;
	}
	int mid=(l+r)>>1;
	if(L<=mid)
	update(l,mid,L,R,root<<1);
	if(R>mid) 
	update(mid+1,r,L,R,root<<1|1);
	
}
void cou(int l,int r,int root,LL s){
	if(l==r){
		if(l==1){
			printf("%d",s+sum[root]);
		}
		else
		printf(" %d",sum[root]+s);return;
	}
	int mid=(l+r)>>1;
	if(l<=mid){
		cou(l,mid,root<<1,s+sum[root]);
	}
	if(r>mid)
	cou(mid+1,r,root<<1|1,s+sum[root]);
}
int main(){
	int T;	int a,b;
	while(~scanf("%d",&T)&&T!=0){
		build(1,T,1);//建树 
		int n=T;
		while(T--){
		
			scanf("%d %d",&a,&b);
			update(1,n,a,b,1);
		}
		cou(1,n,1,0);
	puts("");
	}
}

  

转载于:https://www.cnblogs.com/Yum20/p/9625345.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值