PAT-PAT (Advanced Level) Practise 1005. Spell It Right (20) (简单模拟题)【一星级】

题目链接:http://www.patest.cn/contests/pat-a-practise/1005


题面:

1005. Spell It Right (20)


Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five


题目大意:

    将各位数相加,再将得到的结果,一位一位用英文输出。


解题:

    模拟就好,注意0的情况。


代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
#include <map>
using namespace std;
int main()
{
	string s,ans;
	cin>>s;
	map <int,string> refl;
	//映射关系
	refl[0]="zero";
	refl[1]="one";
	refl[2]="two";
	refl[3]="three";
	refl[4]="four";
	refl[5]="five";
	refl[6]="six";
	refl[7]="seven";
	refl[8]="eight";
	refl[9]="nine";
	int sum=0;
	//相加
	for(int i=0;i<s.length();i++)
		sum+=(s[i]-'0');
    while(sum)
	{
		ans+=(sum%10+'0');
		sum/=10;
	}
	//输出
	if(ans.length()==0)
	  cout<<"zero";
	else
	{
		cout<<refl[ans[ans.length()-1]-'0'];
		for(int i=ans.length()-2;i>=0;i--)
			cout<<" "<<refl[ans[i]-'0'];
	}
	cout<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值