ZOJ Problem Set–1526 Big Number

Time Limit: 10 Seconds      Memory Limit: 32768 KB


In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= n <= 10^7 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2
10
20

Sample Output
7
19


Source: Asia 2002, Dhaka (Bengal)

解此题的时候有一个疑惑:floor(double) 和 (int)double 有什么区别?前者取不大于指定参数的最大整数,后者抛弃了小数部分,两者不相等吗?

 
 
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
 
 
int main()
{
  int cases, n;cin>>cases;
  while(cases-- && cin>>n)
  {
    double digit = 0;
    for(int i = 1; i <= n; i++)
      digit += log(i*1.0);
    cout<<(int)(digit/log(10.0))+1<<endl;
  }
}//AC

 

 
 
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
 
 
int main()
{
  int cases, n;cin>>cases;
  while(cases-- && cin>>n)
  {
    double digit = 0;
    for(int i = 1; i <= n; i++)
      digit += log(i*1.0);
    cout<<floor(digit/log(10.0))+1<<endl;
  }
}//WA

转载于:https://www.cnblogs.com/malloc/archive/2012/03/31/2427427.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值