ZOJ Problem Set–1405 Tanning Salon

Time Limit: 2 Seconds      Memory Limit: 65536 KB


Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write a program that tells the company how many customers left without tanning.

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.

Sample Input

2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0


Sample Output

All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.


Source: Mid-Central USA 2002

注意:当新的顾客来到的时候,如果没有多余的设备,用户可以等待,而不是马上就走了。

 

 
 
#include<iostream>
#include<string>
#include<set>
using namespace std;
 
 
int main()
{
  int salons;
  string customers;
  while(cin>>salons && salons && cin>>customers)
  {
    set<char> inUsed;
    set<char> wait;
    int walkAway = 0;
    for(int i = 0; i < customers.length(); i++)
    {
      if(inUsed.find(customers[i]) != inUsed.end())
      {
        inUsed.erase(customers[i]);
        if(wait.size() != 0)
        {
          inUsed.insert(*wait.begin());
          wait.erase(wait.begin());
        }
      }
      else if(inUsed.size() >= salons)
      {
        if(wait.find(customers[i]) != wait.end())
        {
          wait.erase(customers[i]);
          walkAway++;
        }
        else
          wait.insert(customers[i]);
      }
      else
        inUsed.insert(customers[i]);
    }
    if(walkAway != 0)
    {
      cout<<walkAway<< " customer(s) walked away."<<endl;
    }
    else
    {
      cout<<"All customers tanned successfully."<<endl;
    }
  }
  return 0;
}

转载于:https://www.cnblogs.com/malloc/archive/2012/04/01/2427972.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值