ZOJ Problem Set–2417 Lowest Bit

Time Limit: 2 Seconds      Memory Limit: 65536 KB


Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

Output

For each A in the input, output a line containing only its lowest bit.

Sample Input

26
88
0


Sample Output

2
8


Author: SHI, Xiaohan
Source: Zhejiang University Local Contest 2005

 
 
#include<iostream>
#include<cmath>
using namespace std;
 
 
int main()
{
  int A;
  while(cin>>A && A)
  {
    int i = 0;
    while(A)
    {
      if(A&1 != 0)
      {
        cout<<pow(2.0, i)<<endl;
        break;
      }
      A >>= 1;
      i++;
    }
  }
}

转载于:https://www.cnblogs.com/malloc/archive/2012/04/01/2429137.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值