BZOJ1735Muddy Fields 泥泞的牧场

1735: [Usaco2005 jan]Muddy Fields 泥泞的牧场
Time Limit: 5 Sec Memory Limit: 64 MB
Submit: 244 Solved: 146
Description
Rain has pummeled the cows’ field, a rectangular grid of R rows and C columns (1 <= R <= 50, 1 <= C <= 50). While good for the grass, the rain makes some patches of bare earth quite muddy. The cows, being meticulous grazers, don’t want to get their hooves dirty while they eat. To prevent those muddy hooves, Farmer John will place a number of wooden boards over the muddy parts of the cows’ field. Each of the boards is 1 unit wide, and can be any length long. Each board must be aligned parallel to one of the sides of the field. Farmer John wishes to minimize the number of boards needed to cover the muddy spots, some of which might require more than one board to cover. The boards may not cover any grass and deprive the cows of grazing area but they can overlap each other. Compute the minimum number of boards FJ requires to cover all the mud in the field.
大雨侵袭了奶牛们的牧场.牧场是一个R * C的矩形,其中1≤R,C≤50.大雨将没有长草的土地弄得泥泞不堪,可是小心的奶牛们不想在吃草的时候弄脏她们的蹄子. 为了防止她们的蹄子被弄脏,约翰决定在泥泞的牧场里放置一些木板.每一块木板的宽度为1个单位,长度任意.每一个板必须放置在平行于牧场的泥地里. 约翰想使用最少的木板覆盖所有的泥地.一个木板可以重叠在另一个木板上,但是不能放在草地上.
Input
* Line 1: Two space-separated integers: R and C
* Lines 2..R+1: Each line contains a string of C characters, with ‘*’ representing a muddy patch, and ‘.’ representing a grassy patch. No spaces are present.
第1行:两个整数R和C.
第2到R+1行:每行C个字符,其中“*’代表泥地,“.”代表草地.
Output
* Line 1: A single integer representing the number of boards FJ needs.
最少需要多少木板.
Sample Input
4 4
..
.*
*.
..*.
Sample Output
4
HINT
这里写图片描述
Source
Gold
最小点覆盖。。
二分图匹配。。
附上本蒟蒻的代码:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int n,m,h[100001],part[100001],cnt=1,ans=0,a[51][51],b[51][51];
char s[51][51];
bool used[100001];
struct kx
{
    int to,next;
}edge[100001];

int read()
{
    int w=0,c=1; char ch=getchar();
    while (ch<'0' || ch>'9')
      {
        if (ch=='-') c=-1;
        ch=getchar();
      }
    while (ch>='0' && ch<='9')
      w=w*10+ch-'0',ch=getchar();
    return w*c;
}

void add(int u,int v)
{
    cnt++,edge[cnt].next=h[u],h[u]=cnt,edge[cnt].to=v;
}

bool find(int s)
{
    int k;
    for (k=h[s];k;k=edge[k].next)
      if (!used[edge[k].to])
        {
            used[edge[k].to]=true;
            if (!part[edge[k].to] || find(part[edge[k].to]))
              {
                part[edge[k].to]=s;
                return true;
              }
        }
    return false;
}

int main()
{
    int i,j,xi=0,yi=0;
    n=read(),m=read();
    for (i=0;i<n;i++)
      scanf("%s",&s[i]);
    for (i=0;i<n;i++)
      for (j=0;j<m;j++)
        if (s[i][j]=='*')
          {
            if (j>0 && s[i][j-1]=='*') a[i][j]=a[i][j-1];
            else a[i][j]=++yi;
            if (i>0 && s[i-1][j]=='*') b[i][j]=b[i-1][j];
            else b[i][j]=++xi;
          }
    for (i=0;i<n;i++)
      for (j=0;j<m;j++)
        if (s[i][j]=='*') 
          add(a[i][j],b[i][j]);
    n=yi;
    for (i=1;i<=n;i++)
      {
        memset(used,false,sizeof(used));
        if (find(i)) ans++;
      }
    printf("%d",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值