HDU-1242-Rescu

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27126    Accepted Submission(s): 9607


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
 
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
 
  
13

解题思路:
公主被困了,需要解救,可以有好多个朋友去解救,最近的一个到达公主的房间就算解救成功。遇到士兵可以杀死,但是会额外多增加单位为1的时间。下面给出两种代码,BFS(普通队列)和BFS(优先队列)。截图第一个是BFS(优先队列)



BFS(普通队列)源代码:
<span style="font-size:18px;">//注意:步数最少的路线不一定花费时间最少的,同时当找到解不要立刻退出,
//因为找到的解有可能只能是步数最少解中的最优解,不一定是绝对意义上的最少时间
//不需要设置vis数组,也不用将做过的位置设置为墙壁,因为最少时间有下限,不会有无限循环
#include<stdio.h>
#include<iostream>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<math.h>
#include<string>
#include<string.h>
#define INF 1000000
#define MAX 200
using namespace std;

struct point         //队列所需要要的机构体存储节点
{
    int x, y;        //位置
    int step;        //走到当前位置所用的步数
    int time;        //走到当前位置所花的时间
};
queue<point> Q;      //头文件使用<queue>表示朋友所在的位置
int N, M;
char map[MAX][MAX];  //表示地图
int mintime[MAX][MAX];//每个位置所用的最少时间
int dir[4][2] = { { -1, 0 }, { 1, 0 }, { 0, -1 }, { 0, 1 } };//代表四个方向
int ax, ay;          //angel的位置

int BFS(point s)
{
    int i;
    Q.push(s);
    point hd;//从队列头出队列的位置
    while (!Q.empty())//队列非空
    {
        hd = Q.front();
        Q.pop();
        for (i = 0; i < 4; i++)
        {
            int x = hd.x + dir[i][0];
            int y = hd.y + dir[i][1];
            //排除墙壁和边界
            if (x < N&&x >= 0 && y < M&&y >= 0 && map[x][y] != '#')
            {
                point t;
                t.x = x;
                t.y = y;
                t.step = hd.step + 1;
                t.time = hd.time + 1;
                if (map[x][y] == 'x')
                    t.time = t.time + 1;
                if (t.time < mintime[x][y])
                {
                    mintime[x][y] = t.time;
                    Q.push(t);
                }
            }
        }
    }
    return mintime[ax][ay];
}

int main()
{
    int i, j;
    while (scanf("%d%d", &N, &M) != EOF)
    {
        memset(map, 0, sizeof(map));//读入地图
        for (i = 0; i < N; i++)
            scanf("%s", map[i]);
        int sx, sy;//朋友的位置
        point start;//厨师的队列节点
        for (i = 0; i < N; i++)
        {
            for (j = 0; j < M; j++)
            {
                if (map[i][j] == 'a')
                {
                    ax = i;
                    ay = j;
                }
                else if (map[i][j] == 'r')
                {
                    sx = i;
                    sy = j;
                }
                mintime[i][j] = INF;//寻找最小值,所以初始化为无穷大,并且有了更小的值才会替换
            }
        }
        start.x = sx;
        start.y = sy;
        start.time = 0;
        start.step = 0;
        mintime[sx][sy] = 0;
        int min = BFS(start);
        if (min < INF)
            printf("%d\n", min);
        else
            printf("Poor ANGEL has to stay in the prison all his life.\n");
    }
    return 0;
}</span>

BFS(优先队列)源代码:
<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<cstring>
#include<functional>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<deque>
#include<map>
#include<set>
#include<algorithm>
#include<string>
#include<iomanip>
#include<cstdlib>
#include<cmath>
#include<sstream>
#include<ctime>
using namespace std;

typedef long long ll;
#define eps 1e-6
#define e exp(1.0)
#define pi acos(-1.0)
const int MAXN = 205;
const int MAXM = 205;
const int INF = 0x3f3f3f3f;

typedef struct point
{
    int x;
    int y;
    int time;
    bool operator < (const point &p) const
    {
        return time > p.time;//取用时间占用较少的
    }
};

char Map[MAXN][MAXM];
point start;
int n,m;
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};//方向

int BFS()
{
    point pre;//原来的
    point now;//现在的
    priority_queue<point> q;
    q.push(start);//把天使所在的位置压入
    while(!q.empty())
    {
        pre=q.top();
        q.pop();
        for(int i=0;i<4;i++)
        {
            now.x=pre.x+dir[i][0];
            now.y=pre.y+dir[i][1];
            now.time=pre.time+1;
            if(now.x<0||now.y<0||now.x>=n||now.y>=m)//越界
                continue;
            else if(Map[now.x][now.y]=='#')//墙壁
                continue;
            else if(Map[now.x][now.y]=='r')//朋友
                return now.time;//找到朋友
            else if(Map[now.x][now.y]=='.')
            {
                Map[now.x][now.y]='#';//改成墙壁
                q.push(now);
            }
            else if(Map[now.x][now.y=='x'])//守卫
            {
                now.time++;
                Map[now.x][now.y]='#';//改成墙壁
                q.push(now);
            }
        }
    }
    return -1;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        getchar();
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                scanf("%c",&Map[i][j]);
                if(Map[i][j]=='a')
                {
                    start.x=i;
                    start.y=j;
                    start.time=0;
                    Map[i][j]='#';//顺便改成墙壁
                }
            }
            getchar();
        }
        //输入成功
        int res=BFS();
        if(res==-1)
            printf("Poor ANGEL has to stay in the prison all his life.\n");
        else
            printf("%d\n",res);
    }
	return 0;
}
</span>



转载于:https://www.cnblogs.com/lemonbiscuit/p/7776055.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值