oracle 对应的JDBC驱动 版本

oracle 对应的JDBC驱动 版本

Oracle  版本 jdk版本 推荐jar包 备注
Oracle 8i JDK 1.1.x classes111.zip  
Oracle 8i JDK 1.1.x classes12.zip  
Oracle 9i JDK 1.1.x classes111.jar 或者 classes111.zip  
Oracle 9i JDK 1.2 and JDK 1.3 classes12.jar 或者 classes12.zip  
Oracle 9i JDK 1.4 ojdbc14.jar   
Oracle 9i JDK 1.5 ojdbc5.jar  
Oracle 9i JDK 1.6 ojdbc6.jar  
Oracle 10g JDK 1.2 and JDK 1.3.   classes12.jar   
Oracle 10g JDK 1.4 and 5.0 ojdbc14.jar    
Oracle 11g jdk5 ojdbc5.jar  
Oracle 11g jdk6 ojdbc6.jar

如果一个jdbc的jar包你不知道是那个版本的,可以解压这个jar包,再META-INF\MANIFEST.MF 文件中找文件内容如下.

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.6.5
Created-By: 1.5.0_51-b10 (Sun Microsystems Inc.)
Implementation-Vendor: Oracle Corporation
Implementation-Title: JDBC
Implementation-Version: 11.2.0.4.0
Repository-Id: JAVAVM_11.2.0.4.0_LINUX.X64_RELEASE
Specification-Vendor: Sun Microsystems Inc.
Specification-Title: JDBC
Specification-Version: 4.0
Main-Class: oracle.jdbc.OracleDriver
sealed: true
Name: oracle/sql/converter/
Sealed: false
Name: oracle/sql/
Sealed: false
Name: oracle/sql/converter_xcharset/
Sealed: false
Name: oracle/replay/driver/
Sealed: false


相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页