POJ 3579 Median(2次二分)

Given N numbers, X1,X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi- Xj∣ (1 ≤ i j N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number ifm,the amount of the differences, is even. For example, you have to find the third smallest one in the case ofm = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representingX1, X2, ... ,XN, ( Xi≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input
4
1 3 2 4
3
1 10 2
Sample Output
1
8

  思路:本题直接使用暴力法,时间复杂度约为n^2,超时,所以采用二分法。

  二分差值

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <set>
#include <string>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long ll;
int n,m;
int s[100005];
int judge(int mid)
{
    int cnt=0;
    for(int i=0;i<n;i++)
    {
        cnt=cnt+n-(lower_bound(s,s+n,s[i]+mid)-s); //找出来比s[i]+差值大的数有多少个
    }
    return cnt>m?1:0;
}
int main()
{
    while(scanf("%d",&n)==1)
    {
        m=n*(n-1)/4;
        for(int i=0;i<n;i++)
            scanf("%d",&s[i]);
        sort(s,s+n);
        int l=0,r=s[n-1]-s[0],mid,res;
        while(l<=r)                 //二分差值
        {
            mid=(l+r)/2;
            if(judge(mid))
            {
                 l=mid+1;
                 //res=l;
            }
            else
                r=mid-1;
        }
        printf("%d\n",l-1);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值