HDU1247(Hat’s Words)

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21250    Accepted Submission(s): 7449

Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 
Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 
Sample Input
a ahat hat hatword hziee word
 
Sample Output
ahat hatword
 
题目大意是问你某个单词是否可以拆成单词表中的其他两个单词,如果一个单词中某个部分代表的节点被标记,接着查找剩下的字符能否组成一个单词即可.
 
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<cstdlib>
const int maxn=1000005;
int trie[maxn][27];
int color[maxn];
int k=1;
int cnt=0;
char word[50005][50];
using namespace std;
void _insert(char *w)
{
    int p=0;
    int len=strlen(w);
    for(int i=0;i<len;i++)
    {
        int temp=w[i]-'a';
        if(!trie[p][temp])
        {
            trie[p][temp]=k++;
        }
        p=trie[p][temp];
    }
    color[p]=1;
}
int query(char *w)
{
    int p=0;
    int len=strlen(w);
    for(int i=0;i<len;i++)
    {
        int temp=w[i]-'a';
        if(trie[p][temp])
        {
            p=trie[p][temp];
            if(color[p])//如果某个字符点是终结点,则从下一个字符组成的单词从树中查找。
            {
                int pos=0;
                for(int j=i+1;j<len;j++)
                {
                    int temp2=w[j]-'a';
                    if(!trie[pos][temp2])
                    {
                        break;
                    }
                    pos=trie[pos][temp2];
                    if(j==len-1&&color[pos]==1)
                    {
                        return 1;
                    }
                }
            }
        }
        else
            return 0;
    }
    return 0;
}
int main()
{
    while(scanf("%s",word[cnt])!=EOF)//一开始的单词即为字典序输入,所以可以直接输出.
    {
        _insert(word[cnt]);
        cnt++;
    }
    for(int i=0;i<cnt;i++)
    {
        if(query(word[i]))
        {
            printf("%s\n",word[i]);
        }
    }
}
View Code

 

转载于:https://www.cnblogs.com/switch-waht/p/11519456.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值