利用JAVA中的endorsed技术解决jar包版本冲突的问题

今天学习webservice的时候遇到了jar版本冲突的问题,jaxws-api.jar与jdk提供的版本不一致导致程序无法运行,为解决这个问题可以有一个方法,利用java的endorsed技术解决,

$JAVA_HOME/jre/lib/目录下新建endorsed文件夹,把新版本的jar放到此目录下,项目在运行时虚拟机会优先使用这些jar包,问题即可解决。

关于endorsed的一些介绍可看一下这哥们的blog

http://blog.csdn.net/solariceberg/article/details/16846547

谢过这哥们!

相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页