HDU 2053 Switch Game

Switch Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10561    Accepted Submission(s): 6426


Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 

Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
 

Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 

Sample Input
  
  
1 5
 

Sample Output
  
  
1 0
Hint
hint
Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.
 

Author
LL
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   2066  2065  1397  2136  1611 
 

Statistic |  Submit |  Discuss |  Note

/*只要是倍数就进行一次开关操作,而每个倍数可以写成两个数相乘的形式比如6:
1*6
2*3
3*2
6*1
中间两次其实没做  所以最后一次就关掉了。

而对于完全平方数又多了个a*a的运算,比上面多一个,那么最后一步一定是开灯操作,所以只要是完全平方数那么就是亮着的。
*/
#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
    double n;
    while(scanf("%lf",&n)!=EOF)
    {
        n=sqrt(n);
        if(n==(int)n)
        printf("1\n");
        else
        printf("0\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值