hdu 1006 Tick and Tick

Tick and Tick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18663    Accepted Submission(s): 4760


Problem Description
The three hands of the clock are rotating every second and meeting each other many times everyday. Finally, they get bored of this and each of them would like to stay away from the other two. A hand is happy if it is at least D degrees from any of the rest. You are to calculate how much time in a day that all the hands are happy.
 

Input
The input contains many test cases. Each of them has a single line with a real number D between 0 and 120, inclusively. The input is terminated with a D of -1.
 

Output
For each D, print in a single line the percentage of time in a day that all of the hands are happy, accurate up to 3 decimal places.
 

Sample Input
 
  
0 120 90 -1
 

Sample Output
 
  
100.000 0.000 6.251
 

Author
PAN, Minghao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1007  1009  1011  1012  1024 
题意是说时分秒三个的夹角都相差D时,每一个针都会开心,这题我是看了http://blog.csdn.net/a402630999/article/details/8130308的题解,才有点理解,涉及到角速度和区间求值。。。
#include<iostream>
#include<math.h>
#include<string>
using namespace std;
double max(double a,double b,double c)
{
	if(a>=b&&a>=c) return a;
	else if(b>c&&b>a) return b;
	else return c;
}
double min(double a,double b,double c)
{
	if(a<=b&&a<=c) return a;
	else if(b<c&&b<a) return b;
	else return c;
}
int main()
{// 白天12个小时和晚上12个小时的概率相同 
	double ss,mm,hh,sm,mh,sh,t_sm,t_mh,t_sh;
	ss=6.0;//角速度
	mm=0.1;
	hh=0.1/12.0;
	sm=ss-mm;//相对速度 
	mh=mm-hh;
	sh=ss-hh;
	t_sm=360.0/sm;//相对周期
	t_mh=360.0/mh;
	t_sh=360.0/sh;
	int d;
	double m[3],n[3],x[3],y[3];
	while(cin>>d)
	{
	   if(d==-1) break;
	   x[0]=d/sm;//第一次满足条件的时间 
	   x[1]=d/mh;
	   x[2]=d/sh;
	   y[0]=(360.0-d)/sm;//第一个不满足条件的时间 
	   y[1]=(360.0-d)/mh;
	   y[2]=(360.0-d)/sh;
	   double st,ed,ans=0;
	   for(m[0]=x[0],n[0]=y[0];m[0]<=43200;m[0]+=t_sm,n[0]+=t_sm)
	   {
	   		 for(m[1]=x[1],n[1]=y[1];m[1]<=43200;m[1]+=t_mh,n[1]+=t_mh)
	   		 {
	   		 	  if(m[0]>n[1]) continue;//h满足条件的大于s不满足条件的 继续 
	   		 	  if (n[0]<m[1]) break; 
	   		 	 for(m[2]=x[2],n[2]=y[2];m[2]<=43200;m[2]+=t_sh,n[2]+=t_sh)
				 {
				 	if(n[2]<m[1]||n[2]<m[0]) continue;
					if(m[2]>n[0]||m[2]>n[1]) break;
					st=max(m[0],m[1],m[2]);
					ed=min(n[0],n[1],n[2]);
					if(ed>st) ans+=ed-st; 
				  } 
		  }	
	   }
	   printf("%.3lf\n",ans/432.0);
}
}


 

转载于:https://www.cnblogs.com/xunalove/p/6809222.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值