F Decimal integer conversion

Decimal integer conversion

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
XiaoMing likes mathematics, and he is just learning how to convert numbers between different bases , but he keeps making errors since he is only 6 years old. Whenever XiaoMing converts a number to a new base and writes down the result, he always writes one of the digits wrong. For example , if he converts the number 14 into binary (i.e., base 2), the correct result should be "1110", but he might instead write down "0110" or "1111". XiaoMing never accidentally adds or deletes digits, so he might write down a number with a leading digit of " 0" if this is the digit she gets wrong. Given XiaoMing 's output when converting a number N into base 2 and base 3, please determine the correct original value of N (in base 10). (N<=10^10) You can assume N is at most 1 billion, and that there is a unique solution for N. 
输入
The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8)
Each test case specifies:
* Line 1: The base-2 representation of N , with one digit written incorrectly.
* Line 2: The base-3 representation of N , with one digit written incorrectly.
输出
For each test case generate a single line containing a single integer , the correct value of N
样例输入
1
1010
212
样例输出
14
来源
河南省第九届省赛

解题思路:

//小明总是把一个十进制数装换为2进制或者3进制的数,
//但是他总是写错装换后进制的一位,求正确的十进制数

我的代码:

//小明总是把一个十进制数装换为2进制或者3进制的数,
//但是他总是写错装换后进制的一位,求正确的十进制数
#include<bits/stdc++.h>
#define LL long long int
using namespace std;
char a[1000001],b[1000001];
LL bin2(char a[],LL len)
{
    LL sum=0;
    for(LL i=0;i<len;i++)
        sum=sum*2+a[i]-'0';
    return sum;
}
LL bin3(char a[],LL len)
{
    LL sum=0;
    for(LL i=0;i<len;i++)
        sum=sum*3+a[i]-'0';
    return sum;
}
int main()
{
    int num;
    scanf("%d",&num);
    while(num--)
    {
        scanf("%s",a);
        scanf("%s",b);
        LL r1[10005],r2[10005],ok1=0,ok2=0,len1,len2;
        len1=strlen(a);
        len2=strlen(b);
        for(LL i=0;i<len1;i++)
        {
            if(a[i]=='0')
            {
                a[i]='1';
                r1[ok1++]=bin2(a,len1);
                a[i]='0';
            }
            else
            {
                a[i]='0';
                r1[ok1++]=bin2(a,len1);
                a[i]='1';
            }
        }
        for(LL i=0;i<len2;i++)
        {
            if(b[i]=='0')
            {
                b[i]='1';
                r2[ok2++]=bin3(b,len2);
                b[i]='2';
                r2[ok2++]=bin3(b,len2);
                b[i]='0';
            }
            else if(b[i]=='1')
            {
                b[i]='0';
                r2[ok2++]=bin3(b,len2);
                b[i]='2';
                r2[ok2++]=bin3(b,len2);
                b[i]='1';
            }
            else if(b[i]=='2')
            {
                b[i]='0';
                r2[ok2++]=bin3(b,len2);
                b[i]='1';
                r2[ok2++]=bin3(b,len2);
                b[i]='2';
            }
        }
        for(LL i=0;i<ok1;i++)
            for(LL j=0;j<ok2;j++)
           {
                if(r1[i]==r2[j])
                {
                     printf("%lld\n",r1[i]);
                }

           }
    }
}



转载于:https://www.cnblogs.com/xunalove/p/6809142.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值