1005. Spell It Right

1005. Spell It Right (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

解题思路:这题很水,光看样例就懂了,给你一个数,将其所有的位数加起来,然后按照英文单词输出。。


代码如下:

#include<stdio.h>
#include<math.h>
#include<string.h>
#define LL long long
char a[10][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int main()
{
    char str[101];
    int sum=0,j=0;
    scanf("%s",str);
    for(int i=0;str[i]!='\0';i++)
        sum+=str[i]-'0';
    int t1=sum/100;
    int t2=sum%100/10;
    int t3=sum%10;
    if(t1!=0)
        printf("%s %s %s\n",a[t1],a[t2],a[t3]);
    else
    {
        if(t2==0) printf("%s\n",a[t3]);
        else printf("%s %s\n",a[t2],a[t3]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值