day 1——ST表练习

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 43893 Accepted: 20585
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N  and Q. 
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题意:查询一个区间的最大值最小值,输出二者的差

#include<iostream>
#include<cstdio>
#include<cstring>
#define N 50101
#define K 17
using namespace std;
int hige[N],n,q,l,r;
int min_rmq[N][K+1];
int max_rmq[N][K+1];
int ff[(1<<K)+1];
void input()//读入数据 
{
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;++i)
    scanf("%d",&hige[i]);
}

void pre_chuli()
{
    for(int i=1;i<=n;++i)//初始化长度为2^0的情况 
    {
        min_rmq[i][0]=hige[i];
        max_rmq[i][0]=hige[i];
    }
    for(int j=1;j<=K;++j)
      for(int i=1;i+(1<<j)-1<=n;++i)//处理min_rmq[][]和max_rmq[][],第一个中括号放开始点的位置,第二个中括号放区间的长度 
      {
          min_rmq[i][j]=min(min_rmq[i][j-1],min_rmq[i+(1<<j-1)][j-1]);
          max_rmq[i][j]=max(max_rmq[i][j-1],max_rmq[i+(1<<j-1)][j-1]);
      }
    memset(ff,-1,sizeof(ff));
    ff[0]=0;
    for(int i=0;i<=K;++i)
    ff[1<<i]=i;
    for(int i=1;i<=(1<<K);++i)//处理当长度为i时,最大的2^t 
    if(ff[i]==-1)
    ff[i]=ff[i-1];
}

int max_query(int l,int r)//区间最大值 
{
    int t=ff[r-l+1];//取长度范围内的最大的2^t 
    return max(max_rmq[l][t],max_rmq[r-(1<<t)+1][t]);
}

int min_query(int l,int r)//区间最小值 
{
    int t=ff[r-l+1];//取长度范围内的最大的2^t 
    return min(min_rmq[l][t],min_rmq[r-(1<<t)+1][t]);
}

int main()
{
    input();
    pre_chuli();
    for(int i=1;i<=q;++i)
    {
        scanf("%d%d",&l,&r);
        printf("%d\n",max_query(l,r)-min_query(l,r));
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/yuemo/p/5491824.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值