[HDU1020] Encoding - 加密

Problem Description

Given a string containing only 'A' - 'Z', we could encode it using the following method.

 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.


2. If the length of the sub-string is 1, '1' should be ignored.

 

给定一个只含有'A'-'Z'的字符串,我们可以用下面的方法对其进行加密:

 

1. 每个含有k个相同字符的子字符串应该被加密为"kX","X"是子字符串中唯一的字符。

 

2. 如果子字符串的长度为1,'1'应该被忽略。

 

Input

 

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists only 'A' - 'Z' and the length is less than 10000.

 

第一行包含一个整数N(1 <= N <= 100)指定数据组数。接下来的N行含有N的字符串。每个字符串只含有'A'-'Z'并且长度小于10000。

 

Output

 

For each test case, output the encoded string in a line.

 

对于每组测试数据,用一行输出加密字符串。

 

Sample Input

 

2

ABC

ABBCCC

 

Sample Output

ABC

A2B3C

 

分析

 

从第二个字符开始,判断它与前面是否相同。维护变量k,初始为1,如果相同k++,如果不相同则按规定输出,且k设为1。但需要注意,到了结尾还需要再次输出。

 

代码

 

Language: C

 

#include <stdio.h>
#include <string.h>
int main()
{
    int n;
    char s[10000];
    scanf("%d", &n);
    while (n--)
    {
        scanf("%s", s);
        int l = strlen(s);
        int k = 1;
        for (int i = 1; i < l; i++)
            if (s[i] == s[i - 1])
                k++;
            else
            {
                if (k > 1)
                    printf("%d", k);
                putchar(s[i - 1]);
                k = 1;
            }
        if (k > 1)
            printf("%d", k);
        putchar(s[l - 1]);
        putchar('\n');
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/collectionne/p/6801606.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值