W - Blocks(POJ3734 矩阵快速幂)

W - Blocks

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6

题意:

有n个盒子排成一列,现在要你给盒子染色,有红,蓝,绿,黄四种颜色,其中红色和绿色染色的必须为偶数个,其余随意,问你有几种方法。

分析:

令a(n)为n个盒子,其中红色和绿色为分别为偶数个的方法

令b(n)为n个盒子,其中红色为奇数和,绿色为偶数个的方法

令c(n)为n个盒子,其中红色和绿色都为奇数个的方法

所以有下列方程成立

a(n)=2∗a(n−1)+2∗b(n−1)a(n)=2*a(n-1)+2*b(n-1)a(n)=2a(n1)+2b(n1)

b(n)=a(n−1)+2∗b(n−1)+c(n−1)b(n)=a(n-1)+2*b(n-1)+c(n-1)b(n)=a(n1)+2b(n1)+c(n1)

c(n)=2∗b(n−1)+2∗c(n−1)c(n)=2*b(n-1)+2*c(n-1)c(n)=2b(n1)+2c(n1)

为了加速该递推式,构建矩阵快速幂即可
[a(n)b(n)c(n)]=[220121022]∗[a(n−1)b(n−1)c(n−1)] \left[ \begin{matrix} a(n)\\ b(n)\\ c(n) \\ \end{matrix} \right]= \left[ \begin{matrix} 2&2&0\\ 1&2&1\\ 0&2&2 \\ \end{matrix} \right] * \left[ \begin{matrix} a(n-1)\\ b(n-1)\\ c(n-1) \\ \end{matrix} \right] a(n)b(n)c(n)=210222012a(n1)b(n1)c(n1)

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<iostream>
#include<iomanip>
#include<stack>
#include<vector>
#define mset(a,b)   memset(a,b,sizeof(a))
using namespace std;
typedef unsigned long long ull;
typedef long long ll;
const int maxn=3;
const int branch=26;
const int inf=0x3f3f3f3f;
const int MOD=10007;
struct Matrix
{
    int m[maxn][maxn];
    Matrix operator = (const Matrix& b)
    {
        for(int i=0; i<maxn; ++i)
            for(int j=0; j<maxn; ++j)
                m[i][j]=b.m[i][j];
        return *this;
    }
    void Print() const
    {
        for(int i=0; i<maxn; ++i)
        {
            for(int j=0; j<maxn; ++j)
            {
                printf("%d ",m[i][j]);
            }
            printf("\n");
        }
        printf("\n");
    }
};
Matrix operator *(const Matrix& a,const Matrix& b)
{
    Matrix ans;
//    a.Print();
//    b.Print();
        for(int i=0; i<maxn; ++i)
            for(int j=0; j<maxn; ++j)
            {
                ans.m[i][j]=0;
                for(int k=0; k<maxn; ++k)
                    ans.m[i][j]=(ans.m[i][j]+a.m[i][k]*b.m[k][j])%MOD;
            }
//    ans.Print();
    return ans;
}
Matrix quick_pow(Matrix a,int b)
{
    Matrix ans;
    mset(ans.m,0);
    for(int i=0; i<maxn; ++i)
        ans.m[i][i]=1;
    while(b)
    {
        if(b&1)
            ans=ans*a;
        b/=2;
        a=a*a;
    }
    return ans;
}
int solve(int n)
{
    Matrix ans;
    ans.m[0][0]=2,ans.m[0][1]=2,ans.m[0][2]=0;
    ans.m[1][0]=1,ans.m[1][1]=2,ans.m[1][2]=1;
    ans.m[2][0]=0,ans.m[2][1]=2,ans.m[2][2]=2;
    ans=quick_pow(ans,n-1);
    return (ans.m[0][0]*2+ans.m[0][1])%MOD;
}
int main()
{
    int n,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        printf("%d\n",solve(n));
    }
    return 0;
}

转载于:https://www.cnblogs.com/dchnzlh/p/10427266.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值