Eclipse下为Nokia做J2ME开发

1 软件准备

1.1 Eclipse3.1(http://www.eclipse.org)

1.2 EclipseMe1.2.1(http://eclipseme.org/)

不是最新的就一定好,我试过eclipseMe1.2.2 和eclipse3.2M4的就是不行。:(

1.3 Nokia sdk 4.0

安装nokia sdk的时候,有个选择是否与eclipse集成,最好不选这个。我没有试过。:)

当然还要安装j2sdk 和 wtk.

2 软件配置

2.1 在eclipse上安装eclipseme后,以参数 -clean 的方式重新启动eclipse, 这是为了强制eclipse重新parse所有的plugins。

2.2 设置eclipse的preference:

2.2.1 参考http://eclipseme.org/docs/configuring.html#step4

到这为止,环境上就没有问题了,要注意的一点是,默认情况下生成的Jar文件没有带上资源文件,简单的解决方法就是把所需要的资源文件用winrar放到jar包里

阅读更多

没有更多推荐了,返回首页