2015 Multi-University Training Contest 2 1006(DFS)

Friends

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
There are n people and m pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these n people wants to have the same number of online and offline friends (i.e. If one person has x onine friends, he or she must have x offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements.
 

 

Input
The first line of the input is a single integer T (T=100), indicating the number of testcases.

For each testcase, the first line contains two integers n (1n8) and m (0mn(n1)2), indicating the number of people and the number of pairs of friends, respectively. Each of the next m lines contains two numbers x and y, which mean x and y are friends. It is guaranteed that xy and every friend relationship will appear at most once.
 

 

Output
For each testcase, print one number indicating the answer.
 

 

Sample Input
2
3 3
1 2
2 3
3 1
4 4
1 2
2 3
3 4
4 1
 

 

Sample Output
0
2
 

题意:有N个人有M个关系,每两个人的关系有线上关系和线下关系两种,要使每个人与其他人的线上好友和线下好友数量相等,求有多少种安排方法?

分析:考虑到人数很少,所以可以考虑暴力枚举每一条边,但总边数也有(8 * 7) / 2 = 28条边,最后要求线上好友和线下好友人数相等,所以每个人的好友不能为奇数,再去枚举每一条边。

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
using namespace std;
const int MAXN=10+5;
int kase,n,m,ans;
int e[50][2],l[MAXN],r[MAXN],tot[MAXN];

void DFS(int cur)
{
    if(cur==m)
    {
        for(int i=1;i<=n;i++)
        {
            if(l[i]!=r[i])
                return ;
        }
        ans++;
        return ;
    }
    int tmpl=e[cur][0],tmpr=e[cur][1];
    if(l[tmpl]+1 <= tot[tmpl]/2 && l[tmpr]+1 <= tot[tmpr]/2)//线上好友
    {
        l[tmpl]++;
        l[tmpr]++;
        DFS(cur+1);
        l[tmpl]--;
        l[tmpr]--;
    }
    if(r[tmpl]+1 <= tot[tmpl]/2 && r[tmpr]+1 <= tot[tmpr]/2)//线下好友
    {
        r[tmpl]++;
        r[tmpr]++;
        DFS(cur+1);
        r[tmpl]--;
        r[tmpr]--;
    }

}
int main()
{
    scanf("%d",&kase);
    while(kase--)
    {
        int i;
        memset(tot,0,sizeof(tot));
        memset(e,0,sizeof(e));
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));

        scanf("%d %d",&n,&m);
        for(i=0;i<m;i++)
        {
            scanf("%d %d",&e[i][0],&e[i][1]);//一条边上的两个点
            tot[e[i][0]]++;
            tot[e[i][1]]++;//点的度
        }
        for(i=1;i<=n;i++)
            if(tot[i]%2)
                break;
        if(i<=n) {printf("0\n"); continue;}
        ans=0;
        DFS(0);
        printf("%d\n",ans);
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/clliff/p/4671599.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值