2015 Multi-University Training Contest 5 1002

MZL's xor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 276    Accepted Submission(s): 203


Problem Description
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all ( Ai+Aj)(1i,jn)
The xor of an array B is defined as B1 xor B2...xor Bn
 

 

Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers: n,m,z,l
A1=0,Ai=(Ai1m+z) mod l
1m,z,l5105,n=5105
 

 

Output
For every test.print the answer.
 

 

Sample Input
2
3 5 5 7
6 8 8 9
 

 

Sample Output
14
16
 

 

Source
 
题意:给出n,m,z,l得到Ai的递推式,求所有Ai+Aj的异或值
分析:所有异或的话(Ai+Aj)和(Aj+Ai)会抵消,最后是对所有的2*Ai(1<= i <=n)进行异或
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
int main()
{
    int n,m,z,l,kase;
    scanf("%d",&kase);
    while(kase--)
    {
        scanf("%d %d %d %d",&n,&m,&z,&l);
        LL num=0,ans=0;
        for(int i=2;i<=n;i++)
        {
            num=(num*m+z)%l;
            ans=ans^2*num;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/clliff/p/4703296.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值