HDU 1358 && HDU 3746 && POJ 2406 最小循环节 (KMP)

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4486    Accepted Submission(s): 2164


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

 

Sample Input
3
aaa
12
aabaabaabaab
0
 

 

Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
 
最小循环节还是要自己多去模拟仔细体会
 
HDU 1358 
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
const int MAXN=1000000+5;
char str[MAXN];
int nex[MAXN];
int n;
int Case=0;

void getnext()
{
    int j,k;
    j=0,k=-1,nex[0]=-1;
    while(j<n)
    {
        if(k==-1 || str[j]==str[k])
            nex[++j]=++k;
        else
            k=nex[k];
    }
}
int solve()
{
    getnext();
    int res;
    printf("Test case #%d\n",++Case);
    for(int i=1;i<=n;i++)
    {
        res=i-nex[i];
        if(i%res==0 && i/res>1)
            printf("%d %d\n",i,i/res);
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    Case=0;
    while(scanf("%d",&n) && n)
    {
        scanf("%s",str);
        solve();
        printf("\n");
    }
    return 0;
}
View Code

 

HDU 3746

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
const int MAXN=100000+5;
char str[MAXN];
int nex[MAXN];
int n;

void getnext()
{
    int j=0,k=-1;
    nex[0]=-1;
    while(j<n)
    {
        if(k==-1 || str[j]==str[k])
            nex[++j]=++k;
        else
            k=nex[k];
    }
}
void solve()
{
    getnext();

    int res=n-nex[n];
    if(n%res==0 && n/res>1)
        printf("0\n");
    else
        printf("%d\n",res-nex[n]%res);
}
int main()
{
    //freopen("in.txt","r",stdin);
    int kase;
    scanf("%d",&kase);
    while(kase--)
    {
        scanf("%s",str);
        n=strlen(str);
        solve();
    }
    return 0;
}
View Code

 

POJ 2406

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
const int MAXN=1000000+5;
char str[MAXN];
int nex[MAXN];
int len;
void getnext()
{
    int j,k;
    j=0,k=-1,nex[0]=-1;
    while(j<len)
    {
        if(k==-1 || str[j]==str[k])
            nex[++j]=++k;
        else
            k=nex[k];
    }
}
int main()
{
    while(scanf("%s",str)!=EOF)
    {
        if(str[0]=='.') break;

        len=strlen(str);
        getnext();

        int res=len-nex[len];

        if(len%res==0 && len/res>1) printf("%d\n",len/res);
        else printf("1\n");
    }
    return 0;
}
View Code

 

 

转载于:https://www.cnblogs.com/clliff/p/4718142.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值