poj 2981 Strange Way to Express Integers (中国剩余定理不互质)

http://poj.org/problem?id=2891

Strange Way to Express Integers
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 11970 Accepted: 3788

Description

 

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

 

Choose k different positive integers a1a2…, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1a2, …, ak are properly chosen, m can be determined, then the pairs (airi) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

 

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

 

Sample Input

2
8 7
11 9

Sample Output

31

题目大意: x % ai = ri 求满足条件的最小的x

刚开始看中国剩余定理,直接套用中国剩余定理模板,结果各种RE,原来还有不是两两互质的情况,还是so young 啊!!!!

那么应该怎么处理这种情况呢, 合并方程求解

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<stdlib.h>

using namespace std;

const int N = 1010;
typedef __int64 ll;
ll r, n[N], b[N];

void gcd(ll a, ll b, ll &x, ll &y)
{
    if(b == 0)
    {
        x = 1;
        y = 0;
        r = a;
        return ;
    }
    gcd(b, a % b, x, y);
    ll t = x;
    x = y;
    y = t - a / b * y;
}

ll CRT2(ll n[], ll b[], ll m)
{
    int f = 0;
    ll n1 = n[0], n2, b1 = b[0], b2, c, t, k, x, y;
    for(ll i = 1 ; i < m ; i++)
    {
        n2 = n[i];
        b2 = b[i];
        c = b2 - b1;
        gcd(n1, n2, x, y);//扩展欧几里德
        if(c % r != 0)//无解
        {
            f = 1;
            break;
        }
        k = c / r * x;//扩展欧几里德求得k
        t = n2 / r;
        k = (k % t + t) % t;
        b1 = b1 + n1 * k;
        n1 = n1 * t;
    }
    if(f == 1)
        return -1;
    return b1;
}

int main()
{
    ll k;
    while(~scanf("%I64d", &k))
    {
        for(ll i = 0 ; i < k ; i++)
            scanf("%I64d%I64d", &n[i], &b[i]);
        printf("%I64d\n", CRT2(n, b, k));
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/qq2424260747/p/4962939.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值