BestCoder Round #38 1002——数学——Greatest Greatest Common Divisor

Problem Description

Pick two numbers ai,aj(ij) from a sequence to maximize the value of their greatest common divisor.

Input

Multiple test cases. In the first line there is an integer T, indicating the number of test cases. For each test cases, the first line contains an integer n, the size of the sequence. Next line contains n numbers, from a1 to an1T100,2n105,1ai105. The case for n104 is no more than 10.

Output

For each test case, output one line. The output format is Case #xansx is the case number, starting from 1ans is the maximum value of greatest common divisor.

Sample Input
2
4
1 2 3 4
3
3 6 9
Sample Output
Case #1: 2
Case #2: 3

 大意:最大公约数得一种求法,以i为最大公约数,如果i*j存在的话说明这个数被i整除,只要看有多少个数符合这个条件那么i就是这个最大公约数

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 100010;
int a[MAX];
int num[MAX];
int main()
{
    int temp = 1;
    int n,T;
    scanf("%d",&T);
    while(T--){
        int max1 = 0;
        memset(a,0,sizeof(a));
        memset(num,0,sizeof(num));
        scanf("%d",&n);
        for(int i = 1; i <= n ; i++)
            scanf("%d",&a[i]);
        for(int i = 1; i <= n ; i++)
            num[a[i]]++;
        for(int i = 1; i <= 100000; i++){
            int tot = 0;
            for(int j = 1 ; i*j <= 100000;j++)
                tot += num[i*j];
            if(tot >= 2)
           max1 = max(max1,i);
        }
        printf("Case #%d :%d\n",temp++,max1);
    }
    return 0;
}
View Code

转载于:https://www.cnblogs.com/zero-begin/p/4438143.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值