HDU2126——背包DP(开状态)——Buy the souvenirs

Description

When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance: 



And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10). 
 

Input

For the first line, there is a T means the number cases, then T cases follow. 
In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir. 
All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.
 

Output

If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”
 

Sample Input

2 4 7 1 2 3 4 4 0 1 2 3 4
 

Sample Output

You have 2 selection(s) to buy with 3 kind(s) of souvenirs.
Sorry, you can't buy anything.
大意:给你n个物品你有m块钱,问最多能买几种物品,并且这最多的这种有多少种情况可以选择,
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int dp[550][2];
    int T;
    int w[550];
    int n,m;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        for(int i = 1; i <= n ; i++)
            scanf("%d",&w[i]);
        memset(dp,0,sizeof(dp));
        for(int i = 0 ; i <= m ; i++)
            dp[i][1] = 1;
        for(int i = 1; i <= n ; i++){
            for(int j = m ; j >= w[i]; j--){
                if(dp[j][0] == dp[j-w[i]][0] + 1){//dp[j][0]指用了j钱时的买的礼物数目,如果用j钱买的礼物数目和用不买i物品时所用的钱的买的礼物数目差1,说明用j钱买的礼物的种类就是这两者之和
                    dp[j][1] = dp[j][1] + dp[j-w[i]][1];//
                }
                else if(dp[j][0] < dp[j-w[i]][0] + 1){//如果不大于,说明dp[j-w[i]][0]优于dp[j][0]
                    dp[j][1] = dp[j-w[i]][1];
                    dp[j][0] = dp[j-w[i]][0] + 1;
                }
            }
        }
        if(dp[m][0])
            printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n",dp[m][1],dp[m][0]);
        else printf("Sorry, you can't buy anything.\n");
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/zero-begin/p/4457732.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值