HDU5284——水,strlen坑——wyh2000 and a string problem

Young theoretical computer scientist wyh2000 is teaching young pupils some basic concepts about strings.

A subsequence of a string s is a string that can be derived from s by deleting some characters without changing the order of the remaining characters. You can delete all the characters or none, or only some of the characters.

He also teaches the pupils how to determine if a string is a subsequence of another string. For example, when you are asked to judge whether wyh is a subsequence of some string or not, you just need to find a character w, a y, and an h, so that the w is in front of the y, and the y is in front of the h.

One day a pupil holding a string asks him, "Is wyh a subsequence of this string?"
However, wyh2000 has severe myopia. If there are two or more consecutive character vs, then he would see it as one w. For example, the string vvv will be seen asw, the string vvwvvv will be seen as www, and the string vwvv will be seen as vww.

How would wyh2000 answer this question?

 


Input
The first line of the input contains an integer  T(T105), denoting the number of testcases.

N lines follow, each line contains a string.

Total string length will not exceed 3145728. Strings contain only lowercase letters.

The length of hack input must be no more than 100000.
 


Output
For each string, you should output one line containing one word. Output  Yes if wyh2000 would consider wyh as a subsequence of it, or No otherwise.
 


Sample Input
4 woshiyangli woyeshiyangli vvuuyeh vuvuyeh
 


Sample Output
No Yes Yes No
 


Source
/*
坑点:
strlen的复杂度为O(n)
对于string型的复杂度为O(1)
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int MAX = 3145728 + 5;
char s[MAX];

int main()
{
    int T;
     scanf("%d", &T);
    while(T--){
        scanf("%s", s);
        int pos1 = -1, pos2 = -1, pos3 = -1;
        int n = strlen(s);
    for(int i = 0 ; i < n; ){
        if(s[i] == 'v' && s[i+1] == 'v' && pos1 == -1){
            pos1 = i;
            i += 2;
        }
        else   if(s[i] == 'w' && pos1 == -1){
            pos1 = i;
            i++;
        }
        else   if(s[i] == 'y' && pos1 != -1 && pos2 == -1){
            pos2 = i;
            i++;
        }
        else  if(s[i] == 'h' && pos2 != -1 && pos3 == -1) {
            pos3 = i;
            i++;
        }
        else i++;
    }
    if(pos3 != -1) printf("Yes\n");
    else printf("No\n");
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/zero-begin/p/4661436.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值