HDU5344——数学题——MZL's xor

MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1i,jn)
The xor of an array B is defined as B1 xor B2...xor Bn

 


Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers: n,m,z,l
A1=0,Ai=(Ai1m+z) mod l
1m,z,l5105,n=5105
 


Output
For every test.print the answer.
 


Sample Input
2 3 5 5 7 6 8 8 9
 


Sample Output
14 16
 


Source

 

/*
根据式子可以推出公式为所有值×2的异或和
*/
/************************************************
Author        :powatr
Created Time  :2015-8-5 22:08:30
File Name     :b.cpp
************************************************/

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <sstream>
#include <cstring>
#include <cmath>
#include <string>
#include <vector>
#include <queue>
#include <deque>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <bitset>
#include <cstdlib>
#include <ctime>
using namespace std;

#define lson l, mid, rt << 1
#define rson mid + 1, r, rt << 1 | 1
typedef long long ll;
const int MAX = 1e6 + 10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;

ll a[MAX];
int main(){
    int n, m, z, l;
    int T;
    scanf("%d", &T);
    while(T--){
    scanf("%d%d%d%d", &n, &m, &z, &l);
    a[1] = 0;
        for(int i = 2; i <= n; i++)
            a[i] = (a[i-1]*m + z)%l;
    ll sum = 0;
    for(int i = 1; i <= n; i++)
        sum ^= 1ll*(a[i] << 1);
  printf("%I64d\n", sum);
    }
  return 0;
}  

  

转载于:https://www.cnblogs.com/zero-begin/p/4705998.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值