HDU3047 Zjnu Stadium

本文版权归ljh2000和博客园共有,欢迎转载,但须保留此声明,并给出原文链接,谢谢合作。

 

 

本文作者:ljh2000
作者博客:http://www.cnblogs.com/ljh2000-jump/
转载请注明出处,侵权必究,保留最终解释权!

 
Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
 

 

Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

 

 

Output
For every case:
Output R, represents the number of incorrect request.
 

 

Sample Input
10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100
 

 

Sample Output
2
 
 
 
 
正解:带权并查集
解题报告:

  带权并查集裸题。

  大概就是比并查集多维护了一个dis数组,表示的含义就是一个到根的距离。

  每次我路径压缩的时候顺便把父亲节点的距离加到儿子节点上就可以了,有一定像延迟标记。

  合并的时候,画个图看看就可以发现,如果合并的是x、y,权值为z,集合的代表元素分别为r1,r2,则dis[r2]=dis[x]+z-dis[y]。直接做就可以了。

 

 

//It is made by ljh2000
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <ctime>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <string>
#include <complex>
using namespace std;
typedef long long LL;
const int MAXN = 50011;
int n,m,ans,father[MAXN],dis[MAXN];

inline int getint(){
    int w=0,q=0; char c=getchar(); while((c<'0'||c>'9') && c!='-') c=getchar();
    if(c=='-') q=1,c=getchar(); while (c>='0'&&c<='9') w=w*10+c-'0',c=getchar(); return q?-w:w;
}

inline int find(int x){
	if(father[x]==x) return x;
	int t=father[x]; father[x]=find(father[x]);
	dis[x]+=dis[t]; return father[x];
}

inline bool check(int x,int y,int z){
	int r1=find(x),r2=find(y);
	if(r1==r2) { if(dis[y]!=dis[x]+z) return false; return true; }
	dis[r2]=dis[x]+z-dis[y];//可以画图看看距离的计算式
	father[r2]=r1;
	return true;
}

inline void work(){
	while(scanf("%d%d",&n,&m)!=EOF) {
		for(int i=1;i<=n;i++) father[i]=i,dis[i]=0;
		int x,y,z; ans=0;
		for(int i=1;i<=m;i++) {
			x=getint(); y=getint(); z=getint();
			if(!check(x,y,z)) ans++;
		}
		printf("%d\n",ans);
	}
}

int main()
{
    work();
    return 0;
}

  

转载于:https://www.cnblogs.com/ljh2000-jump/p/6408800.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值