ACM2026

/*

首字母变大写

Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 
Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 
Output
请输出按照要求改写后的英文句子。
 
Sample Input
i like acm i want to get an accepted
 
Sample Output
I Like Acm I Want To Get An Accepted
*/
#include<iostream> #include<cstring> int main() { using namespace std; char a[101],t; int i,l; while(1) { cin.getline(a,101); t='0'; l=strlen(a); a[0]=toupper(a[0]); for(i=1;i<l;i++) if(a[i-1]==' ') a[i]=toupper(a[i]); puts(a); } return 0; }

 

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    char ch[100];
    bool flag=0;
    char f;
    while(gets(ch)){
        int len=strlen(ch);
        f=ch[0]-32;
        cout<<f;
        for(int i=1;i<len;i++){
            if(flag==1){
                 f=ch[i]-32;
                 cout<<f;
                 flag=0;
            }
            else cout<<ch[i];
            if(ch[i]==' ') flag=1;
            
        }
        cout<<endl;
    }
}

 

转载于:https://www.cnblogs.com/orangebook/p/3182221.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值