Commando War

Commando War

“Waiting for orders we held in the wood, word from the front never came

By evening the sound of the gunfire was miles away

Ah softly we moved through the shadows, slip away through the trees

Crossing their lines in the mists in the fields on our hands and our knees

And all that I ever, was able to see

The fire in the air, glowing red, silhouetting the smoke on the breeze”

 

There is a war and it doesn’t look very promising for your country. Now it’s time to act. You have a commando squad at your disposal and planning an ambush on an important enemy camp located nearby. You have N soldiers in your squad. In your master-plan, every single soldier has a unique responsibility and you don’t want any of your soldier to know the plan for other soldiers so that everyone can focus on his task only. In order to enforce this, you brief every individual soldier about his tasks separately and just before sending him to the battlefield. You know that every single soldier needs a certain amount of time to execute his job. You also know very clearly how much time you need to brief every single soldier. Being anxious to finish the total operation as soon as possible, you need to find an order of briefing your soldiers that will minimize the time necessary for all the soldiers to complete their tasks. You may assume that, no soldier has a plan that depends on the tasks of his fellows. In other words, once a soldier begins a task, he can finish it without the necessity of pausing in between.

 

Input

There will be multiple test cases in the input file. Every test case starts with an integer N (1 ≤ N ≤ 1000), denoting the number of soldiers. Each of the following N lines describe a soldier with two integers B (1 ≤ B ≤ 10000) & J (1 ≤ J ≤ 10000). B seconds are needed to brief the soldier while completing his job needs J seconds. The end of input will be denoted by a case with N = 0. This case should not be processed.

 

Output

For each test case, print a line in the format, ‘Case X: Y ’, where X is the case number & Y is the total number of seconds counted from the start of your first briefing till the completion of all jobs.

 

Sample Input

3
2 5
3 2
2 1
3
3 3
4 4
5 5

0

 

Sample Output

Case 1: 8

Case 2: 15

 

此题仍然是采用贪心法,将每个偶序按照 Job Seconds 为关键字从大到小排序。

下证贪心法正确性。

证:

首先,任两偶序之间交换不影响两偶序的前面或后面的偶序的Brief开始时间。

其次,任两偶序之间交换对两偶序的completion时间的影响如下

分两种情形讨论:

设X、Y为两偶序,B[i]、J[i]分别为Brief Seconds、Job Seconds 默认一开始X先于Y。

1.若J[X]>(B[Y]+J[Y]),则交换只能无谓的增加两偶序的completion时间,交换无意义。

2.若J[X]<(B[Y]+J[Y]),则交换前两偶序的completion时间为B[X]+B[Y]+J[Y]

                                           交换后两偶序的completion时间为B[Y]+B[X]+J[X]

不难发现,此情形下两偶序的completion时间大小仅与J[X]、J[Y]的大小有关。

综上所述,贪心策略为:若J[X]>=J[Y],X偶序排在Y偶序之前最优。

 

#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
#include<cmath>
using namespace std;

int max(int a,int b)
{
    return a>b?a:b;
}

struct Job
{
    int j, b;
    bool operator < (const Job& x) const
    {
        return j > x.j;
    }
};
int main()
{
    int n, b, j, kase = 1;
    while(cin>>n && n)
    {
        vector<Job>v;
        for(int i = 0; i < n; i++)
        {
            cin>>b>>j;
            Job job;
            job.j = j , job.b = b;
            v.push_back( job );
        }
        sort(v.begin(), v.end());
        int s = 0;
        int ans = 0;
        for(i = 0; i < n; i++)
        {
            s += v[i].b;
            ans = max(ans,s+v[i].j);
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jianqian/p/4972927.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值