POJ 3667 Hotel

Hotel
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 19938 Accepted: 8653

Description

The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ XiN-Di+1). Some (or all) of those rooms might be empty before the checkout.

Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and Di (b) Three space-separated integers representing a check-out: 2, Xi, and Di

Output

* Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

Sample Input

10 6
1 3
1 3
1 3
1 3
2 5 5
1 6

Sample Output

1
4
7
0
5



代码:
#include <algorithm>
#include <iostream>
#include <cstdio>
#define N 50005
using namespace std;
int cover[N<<2];/// 1:被占领 0:未被占领 -1:不需要更新
int sum[N<<2],
        lsum[N<<2],///从左边数起,连续区间的最大长度
        rsum[N<<2];///从右边数起,连续区间的最大长度

void build(int l,int r,int rt){
    cover[rt] = -1;///初始化均为不用更改的状态
    sum[rt] = lsum[rt] = rsum[rt] = r-l+1;///在 rt 块里 总和和从右向左和从左向右是相同的
    if(l==r)return;
    int m = (l+r)>>1;
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
}

void pushdown(int rt ,int len){
    if(cover[rt] != -1){
        cover[rt<<1] = cover[rt<<1|1] = cover[rt];
        sum[rt<<1] = lsum[rt<<1] = rsum[rt<<1] = cover[rt]? 0 : len-(len>>1);
        sum[rt<<1|1] = lsum[rt<<1|1] = rsum[rt<<1|1] = cover[rt] ? 0 :len>>1;
        cover[rt] = -1;
    }
}

void pushup(int rt,int len){
    lsum[rt] = lsum[rt<<1];     ///左半部分由左边开始的长度
    rsum[rt] = rsum[rt<<1|1];   ///右半部分由右边开始的长度
    if(lsum[rt] == len - (len>>1)){
        lsum[rt]+=lsum[rt<<1|1];/// + 右半部分由左边开始的长度
    }
    if(rsum[rt] == len>>1){
        rsum[rt]+=rsum[rt<<1];
    }
    sum[rt] = max(lsum[rt<<1|1]+rsum[rt<<1],max(sum[rt<<1],sum[rt<<1|1]));
}

int query(int len,int l,int r,int rt){
    if(l==r)return 1;
    pushdown(rt,r-l+1);
    int m = (l+r)>>1;
    if(sum[rt<<1]>=len){
        query(len,l,m,rt<<1);
    }
    else if(rsum[rt<<1]+lsum[rt<<1|1]>=len){
        return m - rsum[rt<<1] +1;
    }
    else return query(len,m+1,r,rt<<1|1);
}

void update(int L ,int R ,int c,int l,int r,int rt){
    if(L <= l and r <= R){
        lsum[rt] = rsum[rt] = sum[rt] = c?0:r-l+1;
        cover[rt] = c;
        return;
    }
    pushdown(rt,r-l+1);
    int m = (l+r)>>1;
    if(m>=L)update(L,R,c,l,m,rt<<1);
    if(m<R)update(L,R,c,m+1,r,rt<<1|1);
    pushup(rt,r-l+1);
}
int n,q,cmd,a,b;
int main(){
    while (cin>>n>>q){
        build(1,n,1);
        while (q--){
            scanf("%d",&cmd);
            if(cmd==1){
                scanf("%d",&a);
                if(sum[1]<a)puts("0");
                else {
                    int ans = query(a, 1, n, 1);
                    printf("%d\n", ans);
                    update(ans, a + ans - 1, 1, 1, n, 1);
                }
            }
            else {
                scanf("%d %d",&a,&b);
                update(a,a+b-1,0,1,n,1);
            }
        }
    }
}

lsum rsum 关系如下

 

转载于:https://www.cnblogs.com/DevilInChina/p/9376836.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值