Box, ACM/ICPC NEERC 2004, UVa1587

                                           Box

Description


Ivan works at a factory that produces heavy machinery. He has a simple job -- he knocks up wooden boxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangular parallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one side of the box.

                                               \epsfbox{p3214.eps}

Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes -- he brings Ivan pallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot of time to explain Joe that he has made a mistake. Fortunately, Joe adores everything related to computers and sincerely believes that computers never make mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a program that given sizes of six rectangular pallets tells whether it is possible to make a box out of them.

Input 

Input file contains several test cases. Each of them consists of six lines. Each line describes one pallet and contains two integer numbers w and h ( 1$ \le$wh$ \le$10 000) -- width and height of the pallet in millimeters respectively.

Output 

For each test case, print one output line. Write a single word `  POSSIBLE ' to the output file if it is possible to make a box using six given pallets for its sides. Write a single word `  IMPOSSIBLE ' if it is not possible to do so.

Sample Input 

1345 2584
2584 683
2584 1345
683 1345
683 1345
2584 683
1234 4567
1234 4567
4567 4321
4322 4567
4321 1234
4321 1234

Sample Output 

POSSIBLE
IMPOSSIBLE


在输入矩形的长和宽时,进行比较,大者赋值给前一个变量;

之后对数据排序;

分别判断1、2,3、4,5、6的矩形的长和宽能否构成一组矩形的面;

判断这三组平面能否构成一个矩形。


#include<stdio.h>
struct pallet
{
    int long1;
    int short2;
}test[6];
int main()
{
    int width, height;
    while(scanf("%d %d", &width, &height)!=EOF)
    {
        if(width<height)
        {
           int tmp = height;
           height = width;
           width = tmp;
        }
        test[0].long1 = width;
        test[0].short2 = height;
        int i;
        for(i=1; i<6; i++)
        {
            scanf("%d %d", &width, &height);
            if(width<height)
            {
               int tmp = height;
               height = width;
               width = tmp;
            }
        test[i].long1 = width;
        test[i].short2 = height;
        }
        for(i=0; i<6; i++)
          for(int j=5; j>i; j--)
          {
              if(test[j].long1<test[j-1].long1)
              {
                  pallet cmp = test[j];
                  test[j] = test[j-1];;
                  test[j-1] = cmp;
              }
              if((test[j].long1==test[j-1].long1)&&(test[j].short2<test[j-1].short2))
              {
                  pallet temp = test[j];
                  test[j] = test[j-1];;
                  test[j-1] = temp;
              }
          }
        bool flag=true;

        for(i=0; i<3; i++)
          if((test[2*i].long1!=test[2*i+1].long1)||(test[2*i].short2!=test[2*i+1].short2))
            {
                flag = false;
                break;
            }

        if(flag)
          if((test[3].long1!=test[5].long1)||(test[1].short2!=test[3].short2)||(test[1].long1!=test[5].short2))
               flag = false;

        if(flag)
            printf("POSSIBLE\n");
        else
            printf("IMPOSSIBLE\n");
    }
    return 0;
}


 
 


转载于:https://www.cnblogs.com/Genesis2018/p/8304849.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值