数据结构实验之栈四:括号匹配

                                                                                    数据结构实验之栈四:括号匹配

Description

  给你一串字符,不超过50个字符,可能包括括号、数字、字母、标点符号、空格,你的任务是检查这一串字符中的( ) ,[ ],{ }是否匹配。

Input

 输入数据有多组,处理到文件结束。

Output

  如果匹配就输出“yes”,不匹配输出“no”

Sample Input

sin(20+10)
{[}]

Sample Output

yes
no

Hint

 
#include<stdio.h>
#include<string.h>
char a[51];
int main(){
  char test[51];
  while(gets(test)){
     int len=strlen(test), ans=0, flag=0;
     for(int i=0; i<len; i++){
        if(test[i]=='[' || test[i]=='(' || test[i]=='{')
           {  a[ans++] = test[i];  flag = 1; }
        else if( ( test[i]==']'&&a[ans-1]=='[' ) || ( test[i]=='}'&&a[ans-1]=='{' ) || ( test[i]==')'&&a[ans-1]=='(' ) )
            ans--;
        else if( ( test[i]==']'&&a[ans-1]!='[' ) || ( test[i]=='}'&&a[ans-1]!='{' ) || ( test[i]==')'&&a[ans-1]!='(' ) || ( (a[ans-1]==']' || a[ans-1]=='}' || a[ans-1]==')') && ans==0 ) )
            { flag=0; break; }
        }
     if(!ans && flag) printf("yes\n");
     else  printf("no\n");
  }
  return 0;
}


 
      

转载于:https://www.cnblogs.com/Genesis2018/p/8304825.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值