HDU 1789 Doing Homework again

一、题目概述

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15842    Accepted Submission(s): 9219


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

 

Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

 

Sample Output
0 3 5
 
 

二、题目释义

有n门课,每一门课有一个限定的时间和超过时间后罚的分数,然后假定每一天只能完成一门课,问如何安排时间去完成这些课,使得罚分最少并输出。

三、思路分析

罚分大的必须要做,未必是最先的但是必须要做,由此有两种贪心策略,第一对让罚分大的尽可能靠近它的截止日期来完成,二是让截止日期靠前的尽可能多完成

四、AC代码

对罚分进行排序

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

const int N = 1005;

struct course
{
    int dl, scr;

} data[N];

int vis[N];

int cmp (course a, course b)
{
    if (a.scr != b.scr)
        return a.scr > b.scr;
    else return a.dl < b.dl;
}

int main ()
{
    int T;
    scanf ("%d", &T);
    while (T--)
    {
        int n;
        memset (vis, 0, sizeof(vis));
        scanf ("%d", &n);
        for (int i=0; i<n; i++)
            scanf ("%d", &data[i].dl);
        for (int i=0; i<n; i++)
            scanf ("%d", &data[i].scr);
        sort (data, data+n, cmp);
        int ans = 0;
        for (int i=0; i<n; ++i)
        {
            int day = data[i].dl;
            for (; day>=1; day--)
                if(!vis[day])
                {
                    vis[day] = 1;
                    break;
                }
            if(day == 0)
                ans += data[i].scr;
        }
        printf ("%d\n", ans);
    }
    return 0;
}

对截止日期进行排序

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
const int N = 1005;

struct course
{
    int dl,rs;
}a[N];
int flag[N];

void init()
{
    memset(flag,0,sizeof(flag));
}

bool cmp(course& A, course& B)
{
    if(A.dl == B.dl) return A.rs > A.rs;
    return A.dl < B.dl;
}

int main()
{
    int T,n; cin >> T;
    while(T--)
    {
        init();
        cin >> n;
        for(int i=0; i<n; i++)
            cin >> a[i].dl;
        for(int i=0; i<n; i++)
            cin >> a[i].rs;
        sort(a,a+n,cmp);
        int d = 1, sum = 0;
        for(int i=0; i<n; i++)
        {
            if(a[i].dl>=d) {flag[i]=1; d++;}
            else
            {
                int Min = a[i].rs;
                int t = i;
                for(int j=i-1; j>=0; j--)
                {
                    if(flag[j]==1 && a[j].rs<Min)
                    {
                        Min = a[j].rs;
                        t=j;
                    }
                }
                sum += a[t].rs;
                a[t].rs = a[i].rs;
            }
        }
        cout << sum << endl;
    }
    return 0;
}

转载于:https://www.cnblogs.com/EcliWalker/p/8324986.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值