POJ 1273 Drainage Ditches

Description

Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source

USACO 93

题目大意

11mm的网络流。

思路

Dinic

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>

const int maxn=200;
const int maxm=400;
const int inf=0x3f3f3f3f;

int n,m;

struct queue
{
  int head,tail,q[(maxn<<2)+10];

  inline int empty()
  {
    return head==tail;
  }

  inline int push(int x)
  {
    ++tail;
    q[tail]=x;
    return 0;
  }

  inline int front()
  {
    return q[head+1];
  }

  inline int pop()
  {
    if(empty())
      {
    return -1;
      }
    ++head;
    return 0;
  }

  inline int mem()
  {
    head=tail=0;
    return 0;
  }
};

struct graph
{
  int pre[maxm+10],now[maxn+10],son[maxm+10],val[maxm+10],tot,d[maxn+10];
  queue q;

  inline int ins(int a,int b,int c)
  {
    pre[tot]=now[a];
    now[a]=tot;
    son[tot]=b;
    val[tot]=c;
    ++tot;
    pre[tot]=now[b];
    now[b]=tot;
    son[tot]=a;
    val[tot]=0;
    ++tot;
    return 0;
  }

  inline int bfs()
  {
    memset(d,0,sizeof d);
    q.mem();
    q.push(1);
    d[1]=1;
    while(!q.empty())
      {
    int u=q.front(),j=now[u];
    q.pop();
    while(j)
      {
        int v=son[j];
        if((!d[v])&&(val[j]))
          {
        d[v]=d[u]+1;
        if(v==n)
          {
            return 1;
          }
        q.push(v);
          }
        j=pre[j];
      }
      }
    return 0;
  }

  inline int dfs(int u,int ru)
  {
    if(u==n)
      {
    return ru;
      }
    int res=ru,j=now[u];
    while((j)&&res)
      {
    int v=son[j];
    if((val[j])&&(d[v]==d[u]+1))
      {
        int f=dfs(v,std::min(val[j],res));
        if(!f)
          {
        d[v]=0;
          }
        res-=f;
        val[j]-=f;
        val[j^1]+=f;
      }
    j=pre[j];
      }
    return ru-res;
  }

  inline int mem()
  {
    tot=1;
    memset(now,0,sizeof now);
    return 0;
  }
};

int a,b,c,ans;
graph g;

int main()
{
  while(scanf("%d%d",&m,&n)!=EOF)
    {
      ans=0;
      g.mem();
      while(m--)
    {
      scanf("%d%d%d",&a,&b,&c);
      g.ins(a,b,c);
    }
      while(g.bfs())
    {
      ans+=g.dfs(1,inf);
    }
      printf("%d\n",ans);
    }
  return 0;
}

转载于:https://www.cnblogs.com/Canopus-wym/p/10376244.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕业设计,基于SpringBoot+Vue+MySQL开发的公寓报修管理系统,源码+数据库+毕业论文+视频演示 现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本公寓报修管理系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此公寓报修管理系统利用当下成熟完善的Spring Boot框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的MySQL数据库进行程序开发。公寓报修管理系统有管理员,住户,维修人员。管理员可以管理住户信息和维修人员信息,可以审核维修人员的请假信息,住户可以申请维修,可以对维修结果评价,维修人员负责住户提交的维修信息,也可以请假。公寓报修管理系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。 关键词:公寓报修管理系统;Spring Boot框架;MySQL;自动化;VUE
毕业设计,基于SpringBoot+Vue+MySQL开发的社区医院管理系统,源码+数据库+毕业论文+视频演示 信息数据从传统到当代,是一直在变革当中,突如其来的互联网让传统的信息管理看到了革命性的曙光,因为传统信息管理从时效性,还是安全性,还是可操作性等各个方面来讲,遇到了互联网时代才发现能补上自古以来的短板,有效的提升管理的效率和业务水平。传统的管理模式,时间越久管理的内容越多,也需要更多的人来对数据进行整理,并且数据的汇总查询方面效率也是极其的低下,并且数据安全方面永远不会保证安全性能。结合数据内容管理的种种缺点,在互联网时代都可以得到有效的补充。结合先进的互联网技术,开发符合需求的软件,让数据内容管理不管是从录入的及时性,查看的及时性还是汇总分析的及时性,都能让正确率达到最高,管理更加的科学和便捷。本次开发的社区医院管理系统实现了病例信息、字典表、家庭医生、健康档案、就诊信息、前台、药品、用户、用户、用户表等功能。系统用到了关系型数据库中王者MySql作为系统的数据库,有效的对数据进行安全的存储,有效的备份,对数据可靠性方面得到了保证。并且程序也具备程序需求的所有功能,使得操作性还是安全性都大大提高,让社区医院管理系统更能从理念走到现实,确确实实的让人们提升信息处理效率。 关键字:社区医院管理系统;信息管理,时效性,安全性,MySql
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值