[优先队列]Mining

题目描述
A mining base needs to build some robots to collect at least 10000 units of resource. Each robot will start from the base, reach the diggings in S minutes, work for W minutes, and then take C units of resource back to the base in S minutes.
  To speed up this procedure, K robots will be built at the base. It takes M minutes to produce one robot. A robot will be set to start working immediately after it is built, and producing the next robot will be on line right after. This procedure continues untill all the robots are built.
  Due to the limitation of the mining equipments, there can be only one robot digging at the working area. That is, it is only after the currently working robot finishes its collecting work and starts getting back to the base that the next robot can work at the diggings.
  Now it is your job to write a program to simulate this procedure, and find out how many minutes it will take to collect at least 10000 units of resource. 

 

输入
There are several lines of input. Each line contains a test case which consists of 5 integers, namely S, W, C, K, and M. 
 

 

输出
For each test case, you are asked to output an integer t, which is the number of minutes taken to collect at least 10000 units of resource. 
 

 

样例输入

复制样例数据

10 20 10 1 5
样例输出
40005

优先队列模拟
#include <iostream>
#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
typedef long long ll;
using namespace std;

int s,w,c,k,m;
priority_queue<int,vector<int>,greater<int> > q;

int main()
{
    while(scanf("%d%d%d%d%d",&s,&w,&c,&k,&m)!=EOF){
        while(!q.empty()) q.pop();

        int num=10000/c;
        if(10000%c) num++;

        for(int i=1;i<=k;i++) q.push(i*m+s);

        int now=q.top();
        q.pop();

        q.push(now+w+2*s);
        int last=now;

        for(int i=2;i<=num;i++){
            if(q.top()-last<=w) now=last+w;
            else now=q.top();
            q.pop();

            q.push(now+w+2*s);
            last=now;
        }
        now+=w+s;

        printf("%d\n",now);
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/lllxq/p/10443033.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值