CDoj--Search gold(dp)

Search gold

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
Submit Status

Dreams of finding lost treasure almost came true recently. A new machine called 'The Revealer' has been invented and it has been used to detect gold which has been buried in the ground. The machine was used in a cave near the seashore where -- it is said -- pirates used to hide gold. The pirates would often bury gold in the cave and then fail to collect it. Armed with the new machine, a search party went into the cave hoping to find buried treasure. The leader of the party was examining the soil near the entrance to the cave when the machine showed that there was gold under the ground. Very excited, the party dug a hole two feel deep. They finally found a small gold coin which was almost worthless. The party then searched the whole cave thoroughly but did not find anything except an empty tin trunk. In spite of this, many people are confident that 'The Revealer' may reveal something of value fairly soon.

So,now you are in the point(1,1)(1,1) and initially you have 0 gold.In the nn*mm grid there are some traps and you will lose gold.If your gold is not enough you will be die.And there are some treasure and you will get gold.If you are in the point(x,y),you can only walk to point (x+1,y),(x,y+1),(x+1,y+2)(x+1,y),(x,y+1),(x+1,y+2)and(x+2,y+1)(x+2,y+1).Of course you can not walk out of the grid.Tell me how many gold you can get most in the trip.

It`s guarantee that(1,1)(1,1)is not a trap;

Input

first come 22 integers, n,mn,m(1n10001≤n≤1000,1m10001≤m≤1000)

Then follows nn lines with mm numbers aijaij

(100<=aij<=100)(−100<=aij<=100)

the number in the grid means the gold you will get or lose.

Output

print how many gold you can get most.

Sample input and output

Sample InputSample Output
3 3
1 1 1
1 -5 1
1 1 1
5
3 3
1 -100 -100
-100 -100 -100
-100 -100 -100
1

Source

第七届ACM趣味程序设计竞赛第四场(正式赛)
想出是个dp, 却写不出来;
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;  
int ac[4][2]={0, 1, 1, 0, 1, 2, 2, 1};
int G[1001][1001], vis[1001][1001], dp[1001][1001];
int n, m;
bool Check(int x, int y)
{
    if(x>=1 && x<=n && y>=1 && y<= m)
        return 1;
    return 0;
}
int main()
{
    while(scanf("%d%d", &n, &m) != EOF)
    {
        for(int i=1; i<= n; i++)
            for(int j=1; j<=m; j++)
                scanf("%d", &G[i][j]);
        memset(dp, -1, sizeof(dp));
        dp[1][1]=G[1][1];
        int ans=-1;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
            {
                if(dp[i][j]<0) continue;
                ans=max(dp[i][j], ans);
                for(int k=0; k<4; k++)
                {
                    int x=i+ac[k][0]; int y=j+ac[k][1];
                    if(!Check(x, y)) continue;
                    //printf("%d %d\n", x, y);
                    dp[x][y]=max(dp[i][j]+G[x][y], dp[x][y]);    
                } 
            } 
        printf("%d\n", ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/soTired/p/5296352.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值