UESTC1269 (数组优化)

Description

as we all know, ZhangYu(Octopus vulgaris) brother has a very famous speech - “Keep some distance from me”. 
ZhangYu brother is so rich that everyone want to contact he, and scfkcf is one of them. 
One day , ZhangYu brother agreed with scfkcf to contact him if scfkcf could beat him. 
There are  digits(lets give them indices from  to  and name them ) and some queries.

for each query:

  1. ZhangYu brother choose an index  from  to .
  2. For all indices  (  < ) calculate the difference .
  3. Then ZhangYu brother calculate  ,the sum of all by which are greater than  , and scfkcf calculate  , the sum of all by which are less than .

if  , ZhangYu brother won and did not agree with scfkcf to contact him; 
else if  is equals to  , ZhangYu brother would ignore the result; 
else if  <  , ZhangYu brother lost and agreed with scfkcf to contact him.

Input

The first line contains two integers   denoting the number of digits and number of queries. The second line contains  digits (without spaces) . 
Each of next  lines contains single integer   denoting the index for current query.

Output

For each of  queries print “Keep some distance from me” if ZhangYu won, else print “Next time” if ZhangYu brother ignored the result, else print “I agree” if ZhangYu brother lost in a line - answer of the query.

Sample Input

10 3 
0324152397 


7

Sample Output

Next time 
Keep some distance from me 
I agree

Hint

It's better to use “scanf” instead of “cin” in your code.

分析题吧, 多用一个数组, 少一层循环

#include <cstdio>
const int N = 100001;
int a[N], b[N];
char c[N];
int main()
{
    int n, m;
    while(scanf("%d%d", &n, &m) != EOF)
    {
        b[0]=0;
        scanf("%s", c);
        for(int i = 1; i <= n; i++)
            a[i]=c[i-1]-'0';
        for(int i = 1; i <= n; i++)
            b[i]=b[i-1]+c[i-1]-'0';
        for(int i = 0; i < m; i++)
        {
            int d;
            scanf("%d", &d);
            int tem=(d-1)*a[d]-b[d-1];
            if(tem>0) printf("Keep some distance from me\n");
            else if(tem==0) printf("Next time\n");
            else printf("I agree\n");
        }
    }
    return 0;
}

转载于:https://www.cnblogs.com/soTired/p/5136501.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值