zoj3827--Beauty of Array (dp)

Beauty of Array

 


 

Time Limit: 2 Seconds      Memory Limit: 65536 KB

 


 

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

 

Input

 

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

 

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

 

Output

 

For each case, print the answer in one line.

 

Sample Input

 

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

 

Sample Output

 

105
21
38

 


Author: LIN, Xi
Source: The 12th Zhejiang Provincial Collegiate Programming Contest

 

dp[i]=dp[i-1]+a*(i-pre[a]);

求相邻数组的总和,其中数组中不能有重复的数字。设dp[i]为以a结尾的长度为(1-->n)的子序列的总和,用pre[a]记录数字a最后出现的位置,以1,2,3,2为例

i=1,a=1

dp[i]=1;

i=2,a=2

dp[i]=2+(1+2);

i=3,a=3

dp[i]=3+(2+3)+(1+2+3);

i=4,a=2,pre[2]=2

dp[i]=2+(3+2)+(2+3+{2})+(1+2+3+{2});

#include <cstdio>
#include <cstring>
#include <iostream>
const int N= 100000+100 ;
typedef long long LL;
using namespace std;
int pre[N]; //去掉重复元素 ; 
LL dp[N];   //dp[i]表示以i结尾的所有(不同长度)子序列的和 ; 
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        memset(pre, 0, sizeof(pre));
        int n; scanf("%d", &n);
        for(int i=1; i<= n; i++)
        {
            int a;
            scanf("%d", &a);
            dp[i]=dp[i-1]+(i-pre[a])*a;
            pre[a]=i;
        }
        LL sum=0;
        for(int i=1; i<= n; i++)
            sum+= dp[i];
        printf("%lld\n", sum);
    }
    return 0;
} 

 

转载于:https://www.cnblogs.com/soTired/p/5450710.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值