【枚举判断】Palindromic Squares 回文平方数 (Usaco_Training 1.2)

Palindromic Squares
Rob Kolstad

Palindromes are numbers that read the same forwards as backwards. The number 12321 is a typical palindrome.

Given a number base B (2 <= B <= 20 base 10), print all the integers N (1 <= N <= 300 base 10) such that the square of N is palindromic when expressed in base B; also print the value of that palindromic square. Use the letters 'A', 'B', and so on to represent the digits 10, 11, and so on.

Print both the number and its square in base B.

PROGRAM NAME: palsquare

INPUT FORMAT

A single line with B, the base (specified in base 10).

SAMPLE INPUT (file palsquare.in)

10

OUTPUT FORMAT

Lines with two integers represented in base B. The first integer is the number whose square is palindromic; the second integer is the square itself.

SAMPLE OUTPUT (file palsquare.out)

1 1
2 4
3 9
11 121
22 484
26 676
101 10201
111 12321
121 14641
202 40804
212 44944
264 69696

 

主要是回文数判断和进制转换

C++ Code

/*
ID: jiangzh15
TASK: palsquare
LANG: C++
*/
//    http://oijzh.cnblogs.com/
#include<cstdio>
#include<string>
#include<iostream>
using namespace std;

int n;
char num[20]={'0','1','2','3','4','5','6','7','8','9','A','B','C','D','E','F','G','H','I','J'};

string zhuan(int x,int k)
{
    string s="";
    while(x)
    {
        s+=num[x%k];
        x/=k;
    }
    string ss="";;
    for(int i=s.length()-1;i>=0;i--)
        ss+=s[i];
    return ss;
}

bool hui(string b)
{
    string s;
    for(int i=b.length()-1;i>=0;i--)
        s+=b[i];
    return (s==b);
}

int main()
{
    freopen("palsquare.in","r",stdin);
    freopen("palsquare.out","w",stdout);
    scanf("%d",&n);
    string a,b;
    for(int i=1;i<=300;i++)
    {
        a=zhuan(i,n);
        b=zhuan(i*i,n);
        if(hui(b)) cout<<a<<" "<<b<<endl;
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/oijzh/archive/2012/10/07/2713705.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值