Number Triangles
Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.
PROGRAM NAME: numtri
INPUT FORMAT
The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.
SAMPLE INPUT (file numtri.in)
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
OUTPUT FORMAT
A single line containing the largest sum using the traversal specified.
SAMPLE OUTPUT (file numtri.out)
30
很经典的坐标型动规的题目了,f[i][j]表示当前坐标所能获得的最大值
当前坐标只能由正上面和作上面的坐标得到,所以
f[i][j]=max(f[i-1][j],f[i-1][j-1])+a[i][j];
并且不用判断坐标是否有效(无效的坐标为0,对结果没有任何影响)
还有这里抱怨一下USACO,同一个程序连交了3次!!!第一次居然第一组数据就超时,第二次第六组数据超时,第三次就过了,什么东西啊,一个程序的误差也不能这么大吧!!!
C++ Code
/*
ID: jiangzh15
TASK: numtri
LANG: C++
http://oijzh.cnblogs.com/
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 1010
int n,f[MAXN][MAXN];
int map[MAXN][MAXN];
int main()
{
freopen("numtri.in","r",stdin);
freopen("numtri.out","w",stdout);
scanf("%d",&n);
for(int i=1;i<=n;i++)
for(int j=1;j<=i;j++)
scanf("%d",&map[i][j]);
for(int i=1;i<=n;i++)
for(int j=1;j<=i;j++)
f[i][j]=max(f[i-1][j],f[i-1][j-1])+map[i][j];
int maxx=f[n][1];
for(int i=1;i<=n;i++) maxx=max(maxx,f[n][i]);
printf("%d\n",maxx);
return 0;
}