Balanced Lineup

Balanced Lineup
Time Limit: 5000MS		Memory Limit: 65536K
Total Submissions: 55949		Accepted: 26

220Case Time Limit: 2000MSDescriptionFor the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.InputLine 1: Two space-separated integers, N and Q. Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.OutputLines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.Sample Input6 31734251 54 62 2Sample Output630SourceUSACO 2007 January Silver


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#define max(x,y) x>y?x:y
#define min(x,y) x<y?x:y
const int M = 100000;
int maximum[M][20], minimum[M][20];
void RMQ(int n)
{
	int i, j;
	for(i = 1; i < 20; i++) {
		for(j = 1; j+(1<<i)-1<=n; j++) {
			maximum[j][i] = max(maximum[j][i-1], maximum[j+(1<<i-1)][i-1]);
			minimum[j][i] = min(minimum[j][i-1], minimum[j+(1<<i-1)][i-1]);
		}
	}
}
int main()
{
	int n, q, num[M], i, j, l, r, k;
	while(scanf("%d %d", &n, &q) != EOF) {
		for(i = 1; i <= n; i++) {
			scanf("%d", &num[i]);
			minimum[i][0] = maximum[i][0] = num[i];
		}
		RMQ(n);
		while(q--) {
		scanf("%d %d", &l, &r);
		int len = r-l+1;
		k = 0;
		while(1<<(k+1) <= len) {
			k++;
		}
		//printf("k=%d\n",k);
		int max = max(maximum[l][k],maximum[r-(1<<k)+1][k]);
		int min = min(minimum[l][k],minimum[r-(1<<k)+1][k]);
		printf("%d\n",max-min);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值