POJ1129 dfs涂色

Channel Allocation

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 15222 Accepted: 7721
Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels.

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.
Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,…,I and J. A network with zero repeaters indicates the end of input.

Following the number of repeaters is a list of adjacency relationships. Each line has the form:

A:BCDH

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form

A:

The repeaters are listed in alphabetical order.

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.
Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.
Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0
Sample Output

1 channel needed.
3 channels needed.
4 channels needed.

题目链接 http://poj.org/problem?id=1129

题意

广播站能广播的距离有限,给出各站点在广播范围内的可达其他站点,问,要使各可达站点间频道互不相同,最少要建立多少个广播站?

题解

将在广播范围内点的两点i,j之间的关系表示成i,j之间有边,本题便成了顶点涂色问题。
即一条边连接的两个定点颜色互不相同,使所有顶点上色后所用的颜色最少。
注意:
(1)dfs+回溯+color数组标记涂色情况
(2)颜色的初始值为1而不是0
(3)全部颜色涂完后要用flag标记
(4)所有当前颜色不满足时颜色总数tol+=1,重涂该点
(5)pic和color数组要清零!!!
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>
#include <stack>
#include <queue>
#include <vector>
#define INF 0x3f3f3f3f 
using namespace std;

const int maxn = 30;
int n;
int pic[maxn][maxn];
int color[maxn];
int flag;

int go(int now, int c){
    for(int i=0; i<n; i++){
        if(pic[now][i] && color[i]==c){
            return 0;
        }
    }
    return 1;
}

void dfs(int id, int& tol){
    if(flag) return;
    if(id >= n){
        flag = 1;
        return;
    }
    for(int i=1; i<=tol; i++){  //颜色标号从1开始,代表颜色的种类 
        if(go(id, i)){
            color[id] = i;
            dfs(id+1, tol);
            color[id] = 0;
        }
    }
    if(!flag){
        tol += 1;   //加一种颜色 
        dfs(id, tol);
    }
}

int main(){
    char s[maxn];
    while(scanf("%d", &n) == 1 && n){
        memset(pic, 0, sizeof(pic));
        memset(color, 0, sizeof(color));
        for(int i=0; i<n ;i++){
            scanf("%s", s);
            for(int j=2; j<strlen(s); j++){
                pic[s[0]-'A'][s[j]-'A'] = 1;    //s[0]
            }
        }
        flag = 0;
        int ans = 1;
        dfs(0, ans);
        if(ans == 1){
            printf("1 channel needed.\n");
        }
        else{
            printf("%d channels needed.\n", ans);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值