PAT-A1033. To Fill or Not to Fill (25)

1033. To Fill or Not to Fill (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
ZHANG, Guochuan

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17
Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<stdio.h>


using namespace std;


struct station
{
	double price, dis;
}sta[510];


int cmp(station s1, station s2)
{
	return s1.dis < s2.dis;
}


int main()
{
	int n;
	double Cmax, D, cus;
	cin >> Cmax >> D >> cus >> n;


	for (int i = 0; i < n; i++)
	{
		cin >> sta[i].price >> sta[i].dis;
	}


	sta[n].price = 0;
	sta[n].dis = D;
	sort(sta, sta + n, cmp);
	
	if (sta[0].dis != 0)
		cout << "The maximum travel distance = 0.00" << endl;
	else
	{
		int now = 0;
		double  nowtank = 0, cost = 0, max = Cmax*cus;
		while (now < n)
		{
			int k = -1;
			double minprice = 100000;
			for (int i = now + 1; i <= n&&sta[now].dis + max >= sta[i].dis; i++)
			{
				if (sta[i].price < minprice)
				{
					k = i;
					minprice = sta[i].price;
				}


				if (minprice < sta[now].price)
				{
					k = i;
					break;
				}


			}


			if (k == -1)
				break;


			double need = (sta[k].dis - sta[now].dis) / cus;


			if (sta[k].price < sta[now].price)
			{
				cost += (need - nowtank)*sta[now].price;
				nowtank = 0;
			}
			else
			{
				cost += (Cmax - nowtank)*sta[now].price;
				nowtank = Cmax - need;
			}


			now = k;
		}


		if (now == n)
		{
			printf("%.2lf", cost);
		}
		else
		{
			printf("The maximum travel distance = %.2lf\n", sta[now].dis + max);
		}
	}


	system("pause");
	return 0;


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值